1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25
|
export PYBUILD_BEFORE_TEST=cp -r {dir}/tests {build_dir}
export PYBUILD_TEST_ARGS=-k 'not test_run and not test_invalid_upgrade and not test_default_headers and not test_trace_logging'
%:
dh $@ --with mkdocs,python3 --buildsystem=pybuild
override_dh_auto_build:
dh_auto_build
LC_ALL=C.UTF-8 LANG=C.UTF-8 mkdocs build && mv site html
override_dh_installman:
docbook-to-man debian/manpage.uvicorn.sgml > uvicorn.1
dh_installman
override_dh_clean:
rm -rf html
dh_clean
override_dh_compress:
dh_compress -Xsearch_index.json
|