File: changelog

package info (click to toggle)
python-xlrd 1.1.0-5
  • links: PTS, VCS
  • area: main
  • in suites: bullseye, sid
  • size: 1,396 kB
  • sloc: python: 8,426; makefile: 118
file content (135 lines) | stat: -rw-r--r-- 4,410 bytes parent folder | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
135
python-xlrd (1.1.0-5) unstable; urgency=medium

  * Team upload.
  * Drop python2 support; Closes: #938276

 -- Sandro Tosi <morph@debian.org>  Sun, 15 Dec 2019 15:26:44 -0500

python-xlrd (1.1.0-4) unstable; urgency=medium

  * Team upload

  [ Matthias Klose ]
  * Stop using time.clock, removed in 3.8 (Closes: 943418)

 -- Graham Inggs <ginggs@debian.org>  Fri, 22 Nov 2019 09:14:34 +0000

python-xlrd (1.1.0-3) unstable; urgency=medium

  * Team upload.
  * Reintroduce Python 2 support.

 -- Ondřej Nový <onovy@debian.org>  Tue, 27 Aug 2019 15:24:37 +0200

python-xlrd (1.1.0-2) unstable; urgency=medium

  * Team upload.
  * d/control: Set Vcs-* to salsa.debian.org
  * d/copyright: Fix Format URL to correct one
  * Use 'python3 -m sphinx' instead of sphinx-build for building docs
  * Use debhelper-compat instead of debian/compat.
  * Drop Python 2 support
    - Move runxlrd to python3-xlrd package
  * Enable autopkgtest-pkg-python testsuite.
  * Bump debhelper compat level to 12.

 -- Ondřej Nový <onovy@debian.org>  Mon, 26 Aug 2019 08:04:59 +0200

python-xlrd (1.1.0-1) unstable; urgency=medium

  * New upstream release.
  * Refresh patches after git-dpm to gbp pq conversion.
  * d/control: bump Standards-Version.
  * d/rules: remove symbolic rules to examples during tests.
  * d/compat: switch to debhelper 10.
  * d/watch: switch to HTTPS.
  * d/control: add a package for documentation.

 -- Vincent Bernat <bernat@debian.org>  Tue, 14 Nov 2017 08:20:54 +0100

python-xlrd (1.0.0-1) unstable; urgency=medium

  [ Ondřej Nový ]
  * Fixed VCS URL (https)

  [ Vincent Bernat ]
  * New upstream version.
  * d/patches: remove disable-non-working-tests.patch (needed files are
    now provided).
  * d/control: bump Standards-Version.
  * d/control: build-depends on python{,3}-setuptools.
  * d/rules: re-enable unittests.

 -- Vincent Bernat <bernat@debian.org>  Sun, 03 Jul 2016 19:53:02 +0200

python-xlrd (0.9.4-1) unstable; urgency=medium

  * New upstream release.
  * Bump Standards-Version to 3.9.6.
  * Remove unit tests (as requested by upstream).
  * Update debian/watch to use debian.net redirector.
  * Switch to pybuild. This makes the build reproducible.

 -- Vincent Bernat <bernat@debian.org>  Thu, 20 Aug 2015 10:58:41 +0200

python-xlrd (0.9.2-1) unstable; urgency=low

  [ Jakub Wilk ]
  * Use canonical URIs for Vcs-* fields.

  [ Vincent Bernat ]
  * Promote Debian Python Modules Team as maintainer. Closes: #700555.
  * Switch from dpatch to 3.0 (quilt) format. Closes: #664378.
  * New upstream release. Closes: #682962.
     + Update debian/watch to look at Pypi.
     + Update homepage.
     + Drop shebang patch. Not needed anymore.
  * Bump Standards-Version to 3.9.4.
  * Switch to dh and dh_python2.
  * Enhance long description in debian/control.
  * Add doc-base registration.
  * Update manual page.
  * Switch to machine-readable debian/copyright.
  * Use shipped unittests.
  * Add Python 3 support. Closes: #614503.

 -- Vincent Bernat <bernat@debian.org>  Tue, 11 Jun 2013 15:22:17 +0200

python-xlrd (0.6.1-2) unstable; urgency=low

  [ Sandro Tosi ]
  * debian/control
    - switch Vcs-Browser field to viewsvn

  [ Luca Falavigna ]
  * Switch to python-support.
  * debian/rules: pass --prefix=/usr to setup.py (Closes: #557936).
  * debian/control: bump Standards-Version to 3.8.3, no changes needed.

 -- Debian Python Modules Team <python-modules-team@lists.alioth.debian.org>  Sat, 12 Dec 2009 13:08:41 +0100

python-xlrd (0.6.1-1) unstable; urgency=low

  * New upstream version
  * New Maintainer
  * First release into Debian repository (closes: #366137)
  * new debian/

 -- Thomas Bläsing <thomasbl@pool.math.tu-berlin.de>  Thu, 08 May 2008 21:24:54 +0000

python-xlrd (0.6.1a4-2) UNRELEASED; urgency=low

  * debian/runxlrd.1, debian/manpages: manpage added.
  * debian/copyright: refer to copy of BSD license.
  * debian/docs: install /usr/share/doc/python-xlrd/doc/{compdoc,HISTORY,README,xlrd}.html.
  * debian/examples: install examples.
  * debian/{rules,install}, debian/runxlrd: supply a wrapper script in /usr/bin/runxlrd
    to work around missing #!/usr/bin/python in runxlrd.py.

 -- Joost van Baal <joostvb+debian@uvt.nl>  Thu, 24 May 2007 07:29:28 +0200

python-xlrd (0.6.1a4-1) UNRELEASED; urgency=low

  * Initial Release (closes: #366137)

 -- Joost van Baal <joostvb+debian@uvt.nl>  Mon, 21 May 2007 13:11:02 +0200