1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30
|
UPSTREAM_GIT := https://github.com/openstack/xstatic-bootstrap-datepicker.git
include /usr/share/openstack-pkg-tools/pkgos.make
%:
dh $@ --buildsystem=pybuild --with python3
override_dh_auto_clean:
rm -rf build .stestr *.egg-info
find . -iname '*.pyc' -delete
for i in $$(find . -type d -iname __pycache__) ; do rm -rf $$i ; done
override_dh_auto_build:
echo "Do nothing..."
override_dh_auto_install:
pkgos-dh_auto_install --no-py2
rm -rf $(CURDIR)/debian/python*-xstatic-bootstrap-datepicker/usr/lib/python*/dist-packages/xstatic/pkg/bootstrap_datepicker/data/*
for i in $(CURDIR)/debian/python*-xstatic-bootstrap-datepicker/usr/lib/python*/dist-packages/xstatic/pkg/bootstrap_datepicker/data ; do \
ln -s ../../../../../../../share/javascript/bootstrap/files/js/bootstrap-datepicker.js $$i/bootstrap-datepicker.js ; \
ln -s ../../../../../../../share/javascript/bootstrap/files/js/locales $$i/locales ; \
ln -s ../../../../../../../share/javascript/bootstrap/files/less/datepicker.less $$i/datepicker.less ; \
ln -s ../../../../../../../share/javascript/bootstrap/files/css/datepicker.css $$i/datepicker.css ; \
ln -s ../../../../../../../share/javascript/bootstrap/files/css/datepicker3.css $$i/datepicker3.css ; \
done
override_dh_clean:
dh_clean
rm -rf build
|