1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16
|
Description: Use getfullargspec instead of getargspec for python3.11.
Author: Bas Couwenberg <sebastic@debian.org>
Bug-Debian: https://bugs.debian.org/1050848
Forwarded: not-needed
@@ -289,7 +289,7 @@ class Transport(object):
return response_text
def _get_args(self, mandatory_args, optional_args, function):
- argspec = set(inspect.getargspec(function).args)
+ argspec = set(inspect.getfullargspec(function).args)
function_args = dict()
for name, value in mandatory_args.items():
if name in argspec:
|