File: INSTALL.md

package info (click to toggle)
pywps 4.2.1-1
  • links: PTS, VCS
  • area: main
  • in suites:
  • size: 1,680 kB
  • sloc: python: 5,885; xml: 669; makefile: 52
file content (44 lines) | stat: -rw-r--r-- 905 bytes parent folder | download | duplicates (2)
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
PyWPS 4 Installation
====================

Dependencies
------------

To use PyWPS 4 the third party libraries GIT and GDAL need to be installed in the system.

In Debian based systems these can be installed with:

    $ sudo apt-get install git python-gdal
    
In Windows systems a Git client should be installed (e.g. GitHub for Windows).
    
Install PyWPS 4
---------------

Using pip: 

    $ sudo pip install -e git+https://github.com/geopython/pywps.git@master#egg=pywps

Or in alternative install it manually:

    $ git clone https://github.com/geopython/pywps.git
    
    $ cd pywps/
    
    $ sudo python setup.py install

Install example service
-----------------------

    $ git clone https://github.com/geopython/pywps-flask.git pywps-flask
    

Run example service
-------------------

    $ python demo.py
    
Access example service
----------------------

    http://localhost:5000