File: changelog

package info (click to toggle)
pyxplot 0.9.2-8
  • links: PTS, VCS
  • area: main
  • in suites: buster, sid
  • size: 9,988 kB
  • sloc: ansic: 50,369; xml: 1,339; python: 572; sh: 321; makefile: 93
file content (295 lines) | stat: -rw-r--r-- 11,787 bytes parent folder | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
135
136
137
138
139
140
141
142
143
144
145
146
147
148
149
150
151
152
153
154
155
156
157
158
159
160
161
162
163
164
165
166
167
168
169
170
171
172
173
174
175
176
177
178
179
180
181
182
183
184
185
186
187
188
189
190
191
192
193
194
195
196
197
198
199
200
201
202
203
204
205
206
207
208
209
210
211
212
213
214
215
216
217
218
219
220
221
222
223
224
225
226
227
228
229
230
231
232
233
234
235
236
237
238
239
240
241
242
243
244
245
246
247
248
249
250
251
252
253
254
255
256
257
258
259
260
261
262
263
264
265
266
267
268
269
270
271
272
273
274
275
276
277
278
279
280
281
282
283
284
285
286
287
288
289
290
291
292
293
294
295
pyxplot (0.9.2-8) unstable; urgency=medium

  * use existing doc directory for build-time tests.

 -- Stuart Prescott <stuart@debian.org>  Sun, 24 Feb 2019 23:55:26 +1100

pyxplot (0.9.2-7) unstable; urgency=medium

  [ Ondřej Nový ]
  * d/tests: Use AUTOPKGTEST_TMP instead of ADTTMP
  * d/copyright: Use https protocol in Format field

  [ Stuart Prescott ]
  * Add eps-creation-date-source-date-epoch.patch to set creation times
    based on SOURCE_DATE_EPOCH.
  * Enable additional hardening options for compiler.
  * Update to debhelper-compat (=11).
  * Update documentation paths for debhelper 11.
  * Regenerate plastex-compliant tex file.
  * Require a plastex that can correctly import PIL.
  * Change Vcs-* URLs to salsa.debian.org.
  * Update Standards-Version to 4.3.0 (no changes required).

 -- Stuart Prescott <stuart@debian.org>  Mon, 28 Jan 2019 02:10:23 +1100

pyxplot (0.9.2-6) unstable; urgency=medium

  * Remove /usr/share/doc/pyxplot symlink so that pyxplot-doc no longer needs
    to depend on pyxplot (Closes: #807124).
  * Update build dependencies for GSL 2, change libgsl0-dev to libgsl-dev.
    Thanks to Bas Couwenberg for the patch (Closes: #807223).

 -- Stuart Prescott <stuart@debian.org>  Mon, 07 Dec 2015 03:42:36 +1100

pyxplot (0.9.2-5) unstable; urgency=medium

  * Stop using imagemagick at build time to get away from imagemagick
    transitions (Closes: #761554, #761726).
  * Build-depend on libcfitsio-dev instead of libcfitsio3-dev (Closes: #761717).
  * Bump standards version to 3.9.6 (no changes required).
  * Override lintian warning package-contains-timestamped-gzip about files
    that are in the source package.
  * Add autopkgtest test suite.

 -- Stuart Prescott <stuart@debian.org>  Thu, 18 Sep 2014 00:51:40 +1000

pyxplot (0.9.2-4) unstable; urgency=low

  * Bump standards version to 3.9.4 (no changes required).
  * Move test target into Makefile to simplify debian/rules.
  * Package ready for upload to unstable.

 -- Stuart Prescott <stuart@debian.org>  Wed, 15 May 2013 01:26:07 +1000

pyxplot (0.9.2-3) experimental; urgency=low

  * Make test output unbuffered and don't run really slow tests to prevent
    buildd timeout.

 -- Stuart Prescott <stuart@debian.org>  Tue, 18 Dec 2012 00:15:48 +0000

pyxplot (0.9.2-2) experimental; urgency=low

  * Move texlive-fonts-recommended to Build-Depends since it is now needed by
    the test suite.

 -- Stuart Prescott <stuart@debian.org>  Sat, 15 Dec 2012 17:54:06 +0000

pyxplot (0.9.2-1) experimental; urgency=low

  * New upstream release
  * Drop patches build-hardening.patch, doc-build-redirection.patch
    separate-build-docs.patch, test-some-examples.patch applied upstream.
  * Drop cherry-picked upstream-svn-20120808.patch

 -- Stuart Prescott <stuart@debian.org>  Sat, 15 Dec 2012 16:04:14 +0000

pyxplot (0.9.0-2) experimental; urgency=low

  * Fix doc/Makefile for testing using examples.

 -- Stuart Prescott <stuart@debian.org>  Thu, 09 Aug 2012 00:41:16 +0100

pyxplot (0.9.0-1) experimental; urgency=low

  * New upstream release
  * Build-Depend on libpng-dev rather than libpng12-dev for libpng transition
    (Closes: #662480).
  * Update format URL in debian/copyright.
  * Bump standards version to 3.9.3 (no changes required).
  * Use debhelper 9 and enable hardening flags.

 -- Stuart Prescott <stuart@debian.org>  Tue, 07 Aug 2012 23:14:08 +0100

pyxplot (0.8.4-5) unstable; urgency=low

  * Don't unconditionally build documentation but use some of the examples to
    test the package; thanks to Mehdi Dogguy and Jakub Wilk. (Closes: #655868)

 -- Stuart Prescott <stuart+debian@nanonanonano.net>  Thu, 26 Jan 2012 23:45:15 +0000

pyxplot (0.8.4-4) unstable; urgency=low

  * Add build dependency on libncurses-dev for recent readline changes.

 -- Stuart Prescott <stuart+debian@nanonanonano.net>  Wed, 19 Oct 2011 23:57:48 +0100

pyxplot (0.8.4-3) unstable; urgency=low

  * Set $HOME to a writable location to allow latex to find fonts.

 -- Stuart Prescott <stuart+debian@nanonanonano.net>  Wed, 18 May 2011 01:12:45 +0100

pyxplot (0.8.4-2) unstable; urgency=low

  * Don't divert latex and pyxplot output during build process.
  * Stop scanning documentation for symlinks since plastex no longer generates
    broken symlinks in the documentation tree.

 -- Stuart Prescott <stuart+debian@nanonanonano.net>  Sun, 15 May 2011 17:44:52 +0100

pyxplot (0.8.4-1) unstable; urgency=low

  * New upstream release
  * Update debian/copyright DEP-5 format.
  * Bump standards version to 3.9.2 (no changes required).

 -- Stuart Prescott <stuart+debian@nanonanonano.net>  Sat, 07 May 2011 12:54:49 +0100

pyxplot (0.8.3-1) unstable; urgency=low

  * New upstream (bugfix) release
  * Add additional copyright holders to debian/copyright
  * Set DM-Upload-Allowed: yes

 -- Stuart Prescott <stuart+debian@nanonanonano.net>  Sun, 03 Oct 2010 13:04:39 +0100

pyxplot (0.8.2-1) unstable; urgency=low

  * New upstream release.
    - pyxplot now works on big-endian architectures too (Closes: #591538).
  * Drop gv-not-found.patch (incorporated upstream).
  * Bump standards version to 3.9.1 (no changes required).

 -- Stuart Prescott <stuart+debian@nanonanonano.net>  Sat, 07 Aug 2010 18:33:29 +0100

pyxplot (0.8.1-2) unstable; urgency=low

  * Fix configure script to correctly handle the case where ghostview is not
    installed at configure time.
  * Force use of ghostview even though not installed at configure time
    (Closes: #589696).
  * Use Breaks rather than Conflicts as per §7.6 of policy version 3.9.0.
  * Bump standards version to 3.9.0.

 -- Stuart Prescott <stuart+debian@nanonanonano.net>  Tue, 20 Jul 2010 12:44:04 +0100

pyxplot (0.8.1-1) unstable; urgency=low

  * New upstream release (rewrite in C).
  * Rewrite in C removes python string exceptions problems (Closes: #585345).
  * Update packaging to new release.
  * Split off pyxplot-doc package containing the HTML and PDF documentation;
    Conflict+Replace older versions of the package.
  * Drop gv-wrapper now that upstream has built this functionality into pyxplot.
  * Drop patches for PyX since it is no longer used by pyxplot.
  * Drop makefile-destdir.patch (incorporated upstream).
  * Drop makefile-usrshareman.patch (incorporated upstream).
  * Drop plastex-icons.patch (incorporated upstream).
  * Depend on texlive-latex-extra as upgreek.sty is unconditionally included
    in the latex template.
  * Update watch file now that repackaging the upstream source is not needed.
  * Drop repackaging scripts.
  * Switch to dpkg-source 3.0 (quilt) format.

 -- Stuart Prescott <stuart+debian@nanonanonano.net>  Mon, 14 Jun 2010 23:30:14 +0100

pyxplot (0.7.1+1-2) unstable; urgency=low

  * Change build-dep to use libmagickcore-extra as part of the imagemagick
    transition (Closes: #573972, #574308).
  * Bump standards version to 3.8.4 (no changes required).

 -- Stuart Prescott <stuart+debian@nanonanonano.net>  Wed, 17 Mar 2010 18:55:42 +0000

pyxplot (0.7.1+1-1) unstable; urgency=low

  * New upstream release
  * Use Debian package for PyX not the pyxplot-modified version.
  * Drop manpage_syntax.patch as it is applied upstream.
  * Add build-depends on libmagickcore2-extra since imagemagick has reorganised
    the plugin packages (closes: #560651).

 -- Stuart Prescott <stuart+debian@nanonanonano.net>  Sat, 12 Dec 2009 00:48:45 +0000

pyxplot (0.7.0+1-1) unstable; urgency=low

  * New maintainer. Thanks to Sam Morris for his previous work.
  * New upstream release (closes: #547962).
  * Replace obsolete dependencies on gs-* packages (closes: #534900).
  * Depend on texlive-latex-base to ensure that latex is installed
    (closes: #497918).
  * Move gv to recommends and use a wrapper to find other postscript viewers
    and allow user configuration of this (closes: #492804).
  * Move python-scipy to a Recommends as it is possible to use pyxplot without
    this package installed (closes: #478834).
  * Document recommended packages and the functionality they provide in
    README.Debian.
  * Add menu entry, icons and mime-type assosciation for pyxplot files.
  * Change build system to dh7+quilt.
  * Bump standards version to 3.8.3 (no changes required).

 -- Stuart Prescott <stuart+debian@nanonanonano.net>  Tue, 13 Oct 2009 15:11:08 +0100

pyxplot (0.6.3.1+ds-3) unstable; urgency=low

  * Add Homepage to control fields.
  * Add a copyright notice for Debian packaging to debian/copyright.

 -- Sam Morris <sam@robots.org.uk>  Sun, 04 Nov 2007 10:10:05 +0000

pyxplot (0.6.3.1+ds-2) UNRELEASED; urgency=low

  * Fix copyright file; it now mentions how we turn upstream's source archive
    into the one used for this package.
  * Make the new-upstream script easier to call manually, as opposed to
    automatically from uscan(1): if the --upstream_version argument is not
    specified on the command line, don't run uupdate(1) after repacking the
    upstream tarball.

 -- Sam Morris <sam@robots.org.uk>  Sat, 15 Sep 2007 18:24:00 +0100

pyxplot (0.6.3.1+ds-1) UNRELEASED; urgency=low

  * Repack upstream tarball to remove contained PyX tarball and HTML
    documentation.
    + 200_build-docs-verbose.patch: don't try to unpack PyX's tarball and
      install it along with PyXPlot.
    + No longer any need to build-depend on imagemagick.
    + No longer any need to specify DEB_TARBALL in rules file.
  * Introduce debian/new-upstream which does this for us automatically for
    a new usptream release; call this script from the watch file.

 -- Sam Morris <sam@robots.org.uk>  Sat, 15 Sep 2007 00:24:45 +0100

pyxplot (0.6.3.1-2) UNRELEASED; urgency=low

  * Rename debian/README to debian/README.Debian.
  * Tighten strictness of dependency on python-pyx (as advised by upstream)
    since PyX's API changes break PyXPlot with every new release.
  * Build the documentation in HTML format; also build-depend on
    python-plastex.
  * Now that the HTML documentation is built, there is no longer any need to
    prevent its removal during clean; therefore express the remaining changes
    to doc/Makefile in the form of 200_build-docs-verbose.patch.
  * Add a debian/watch file.

 -- Sam Morris <sam@robots.org.uk>  Sun, 19 Aug 2007 03:26:26 +0100

pyxplot (0.6.3.1-1) UNRELEASED; urgency=low

  * Not a new upstream release... I just didn't notice that the previous
    version was really 0.6.3.1.
  * No longer use tarball-in-a-tarball build system.
  * Set DEB_TARBALL to empty value in rules file so that cdbs does not
    create PyX-0.9.tar.gz.cdbs-config_list.
  * Drop build-dependency on obsolete tetex-bin.
  * Patch doc/Makefile directly in the Debian source patch to prevent HTML
    documentation from being removed on clean. Also prevent LaTeX's output
    from being sent to /dev/null.
  * Install shipped documentation in HTML format, and register it with
    doc-base.
  * Register PDF documentation with doc-base.
  * Build-depend on textlive-latex-recommended and textlive-fonts-recommended
    so that the documentation will build.
  * Build-depend on python-pyx (since it's used directly by pyxplot).
    Currently I think at build-time the pyx module shipped inside the pyxplot
    sources is used... if I later remove this then I'll need Debian's package
    of pyx to be installed.

 -- Sam Morris <sam@robots.org.uk>  Wed, 16 May 2007 23:25:02 +0100

pyxplot (0.6.3-2) UNRELEASED; urgency=low

  * Invoke gv(1) correctly (the - character in '-watch' was ommitted).
  * No need to remove build-stamp in clean, it was cruft from an earlier
    version of the package.

 -- Sam Morris <sam@robots.org.uk>  Wed, 16 May 2007 21:12:48 +0100

pyxplot (0.6.3-1) UNRELEASED; urgency=low

  * Initial release (closes: #405300).

 -- Sam Morris <sam@robots.org.uk>  Tue,  3 Apr 2007 17:26:26 +0100