1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32
|
Author: Pino Toscano <pino@debian.org>
Description: Make the quickjs embedded copy build on GNU/Hurd
Backport/adapt the changes done in the upstream quickjs project for supporting
GNU/Hurd to the embedded copy in qbs:
https://github.com/bellard/quickjs/pull/316
.
This patch can be dropped when qbs rebases its copy to a new version of the
upstream quickjs.
Forwarded: not-needed
Origin: vendor
Last-Update: 2024-12-10
@@ -36,7 +36,7 @@
#include <math.h>
#if defined(__APPLE__)
#include <malloc/malloc.h>
-#elif defined(__linux__)
+#elif defined(__linux__) || defined(__GLIBC__)
#include <malloc.h>
#elif defined(__FreeBSD__)
#include <malloc_np.h>
@@ -1763,7 +1763,7 @@ static size_t js_def_malloc_usable_size(
return _msize((void *)ptr);
#elif defined(EMSCRIPTEN)
return 0;
-#elif defined(__linux__)
+#elif defined(__linux__) || defined(__GLIBC__)
return malloc_usable_size((void *)ptr);
#else
/* change this to `return 0;` if compilation fails */
|