File: rules

package info (click to toggle)
qtscript-opensource-src 5.7.1~20161021+dfsg-2
  • links: PTS, VCS
  • area: main
  • in suites: stretch
  • size: 27,388 kB
  • ctags: 29,813
  • sloc: cpp: 163,688; ansic: 2,206; yacc: 1,768; perl: 425; sh: 169; python: 55; makefile: 18
file content (31 lines) | stat: -rwxr-xr-x 878 bytes parent folder | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
#!/usr/bin/make -f

# Uncomment this to turn on verbose mode.
#export DH_VERBOSE=1

export CFLAGS := $(shell dpkg-buildflags --get CFLAGS) $(shell dpkg-buildflags --get CPPFLAGS)
export CXXFLAGS := $(shell dpkg-buildflags --get CXXFLAGS) $(shell dpkg-buildflags --get CPPFLAGS)
export LDFLAGS := $(shell dpkg-buildflags --get LDFLAGS) -Wl,--as-needed
export QT_SELECT := qt5
export QT_QPA_PLATFORM := minimal

%:
	dh $@ --parallel --with pkgkde_symbolshelper --dbg-package=qtscript5-dbg

override_dh_auto_configure:
	qmake QT_BUILD_PARTS+=tests

override_dh_auto_build-indep:
	dh_auto_build -- docs

override_dh_auto_install-arch:
	dh_auto_install

	# Remove libtool-like files
	rm -f debian/tmp/usr/lib/$(DEB_HOST_MULTIARCH)/*.la

override_dh_auto_install-indep:
	dh_auto_build -- INSTALL_ROOT=$(CURDIR)/debian/tmp install_docs

override_dh_install:
	dh_install --fail-missing