File: configure.ac

package info (click to toggle)
quick-lounge-applet 2.13.2-1
  • links: PTS
  • area: main
  • in suites: squeeze
  • size: 2,656 kB
  • ctags: 546
  • sloc: sh: 9,191; ansic: 6,858; xml: 1,087; makefile: 128
file content (83 lines) | stat: -rw-r--r-- 2,086 bytes parent folder | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
AC_INIT([quick-lounge-applet],[2.13.2],[http://bugzilla.gnome.org/enter_bug.cgi?product=quick-lounge-applet])

GNOME_COMMON_INIT

AC_CONFIG_MACRO_DIR([m4])
AC_CONFIG_HEADERS([config.h])
AC_CONFIG_SRCDIR(src/quick-lounge.c)

AM_INIT_AUTOMAKE([1.9 foreign])

AC_PATH_PROG(GLIB_GENMARSHAL, glib-genmarshal)
AC_PATH_PROG(GLIB_MKENUMS, glib-mkenums)

AM_PROG_LIBTOOL
GNOME_DOC_INIT
GNOME_COMPILE_WARNINGS([maximum])

dnl ==========================================================================
dnl
dnl If you add a version number here, you *must* add an AC_SUBST line for
dnl it too, or it will never make it into the spec file!
dnl
dnl ==========================================================================

GLIB_REQUIRED=2.16.0
GTK_REQUIRED=2.14.0
LIBPANEL_REQUIRED=2.4.0
LIBGNOME_MENU_REQUIRED=2.12.0

AC_SUBST(GLIB_REQUIRED)
AC_SUBST(GTK_REQUIRED)
AC_SUBST(LIBPANEL_REQUIRED)
AC_SUBST(LIBGNOME_MENU_REQUIRED)

dnl ==========================================================================

PKG_CHECK_MODULES(QL,					\
	glib-2.0 >= $GLIB_REQUIRED			\
	gio-2.0						\
	gio-unix-2.0					\
	gthread-2.0					\
	gtk+-2.0 >= $GTK_REQUIRED			\
	libpanelapplet-2.0 >= $LIBPANEL_REQUIRED	\
	libgnome-menu >= $LIBGNOME_MENU_REQUIRED)
AC_SUBST(QL_CFLAGS)
AC_SUBST(QL_LIBS)

dnl ******************************

AC_ARG_ENABLE(deprecations,AC_HELP_STRING([--enable-deprecations],[warn about deprecated usages]))

AM_CONDITIONAL(ENABLE_DEPRECATIONS, test "x$enable_deprecations" = xyes)

dnl ******************************

AC_PATH_PROG(GCONFTOOL, gconftool-2, no)
if test x"$GCONFTOOL" = xno; then
        AC_MSG_ERROR([gconftool-2 executable not found in your path - should be installed with GConf])
fi
AM_GCONF_SOURCE_2

dnl ******************************

IT_PROG_INTLTOOL([0.35.0])

GETTEXT_PACKAGE=quick-lounge-applet
AC_DEFINE_UNQUOTED(GETTEXT_PACKAGE, "$GETTEXT_PACKAGE", [GetText Package])
AC_SUBST(GETTEXT_PACKAGE)

AM_GLIB_GNU_GETTEXT

dnl ******************************

AC_CONFIG_FILES([
Makefile
data/Makefile
data/ui/Makefile
help/Makefile
src/Makefile
po/Makefile.in
])

AC_OUTPUT