File: README

package info (click to toggle)
quvi 0.9.4-1.1
  • links: PTS, VCS
  • area: main
  • in suites: bullseye, buster, stretch
  • size: 2,640 kB
  • ctags: 912
  • sloc: sh: 12,149; ansic: 5,839; makefile: 261; sed: 16
file content (101 lines) | stat: -rw-r--r-- 2,509 bytes parent folder | download | duplicates (2)
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
General
=======

quvi is the command line tool for developing the libquvi scripts and
parsing the media properties.

gitweb: <http://repo.or.cz/w/quvi-tool.git>
Home  : <http://quvi.sourceforge.net/>


Installation
============

Notes
-----

  * This document does not cover how to use GNU Autotools for building
and installing software, instead, refer to the GNU Autotools documentation,
the INSTALL file and the "configure --help" output for more information.

  * If you're not familiar with GNU Autotools and/or installing software
from the source code, you may prefer to install quvi using a binary
package, instead. You can find quvi packaged for many distros already.

  * If you have previously installed quvi from the source code to your
system, the recommended practice is to uninstall the previous installation
first, before you continue with the new one. You would, typically, run
"make uninstall" (as root if necessary) from the same directory you ran
"make install" from.

  * If you are building quvi from the git repository code, run the
`bootstrap.sh' first. This generates the configuration files. See also
the -h output for any additional info.


Simple install procedure
------------------------

  % ./configure && make

  [ Become root if necessary ]
  % make install

The configure script supports also the following options which are
relevant to the installation:

  --with(out)-manual

    Install the manual page for quvi.

Requirements
------------

* libquvi 0.9
  http://quvi.sourceforge.net/

* libcurl 7.21.0
  http://curl.haxx.se/
    $ sudo aptitude install libcurl4-gnutls-dev
       (or libcurl4-openssl-dev)

* GLib 2.24.2
  http://library.gnome.org/devel/glib/
    $ sudo aptitude install libglib2.0-dev

* JsonGlib 0.12
  http://live.gnome.org/JsonGlib
  NOTE: builds without: JSON output will be disabled
    $ sudo aptitude install libjson-glib-dev

* libxml 2.7.8
  http://www.xmlsoft.org/
  NOTE: builds without: XML output will be disabled
    $ sudo aptitude install libxml2-dev

* pkg-config for tracking the compilation flags needed for libraries
  http://www.freedesktop.org/software/pkgconfig/

* GNU gettext is recommended
  http://www.gnu.org/software/gettext/

* GNU make is recommended
  http://www.gnu.org/software/make/


How to report bugs
==================

Please see: http://quvi.sourceforge.net/#bugs


Patches
=======

Please see: http://quvi.sourceforge.net/contrib/


License
=======

quvi is Free Software, licensed under the GNU Affero GPLv3+.