1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26
|
Description: Exclude test requiring websocket
Author: Andreas Tille <tille@debian.org>
Last-Update: Thu, 12 Sep 2019 11:45:57 +0200
@@ -26,14 +26,14 @@
# "Unnecessary" braces here to prevent `later` from attempting to
# run callbacks if this test is pasted at the console
{
- ws_client <- websocket::WebSocket$new(sprintf("ws://127.0.0.1:%s", random_port))
- ws_client$onOpen(function(event) {
- client_on_open_called <<- TRUE
+# ws_client <- websocket::WebSocket$new(sprintf("ws://127.0.0.1:%s", random_port))
+# ws_client$onOpen(function(event) {
+# client_on_open_called <<- TRUE
# NOTE: Depends on websocketpp internals.
# 0 below corresponds to close::status::blank, here:
# https://github.com/rstudio/websocket/blob/f435899aef3eaecf97af9f3febd87687ecddc3a7/src/lib/websocketpp/close.hpp#L51-L52
- ws_client$close(0)
- })
+# ws_client$close(0)
+# })
}
loop_start <- as.numeric(Sys.time())
|