1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25
|
Description: Hack for symlinks to twitter-bootstrap and javascript
Also allow serving /usr/share/javascript and
/usr/share/twitter-boostrap/ from shiny apps by default
Author: Don Armstrong <don@debian.org>
Origin: vendor
Bug-Debian: https://bugs.debian.org/867963
Forwarded: not-needed
Last-Update: 2017-07-10
This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
@@ -288,6 +288,12 @@ resolve <- function(dir, relpath) {
dir <- normalizePath(dir, winslash='/', mustWork=TRUE)
# trim the possible trailing slash under Windows (#306)
if (isWindows()) dir <- sub('/$', '', dir)
+ ## Debian specific hack for /usr/share/javascript symlinks
+ if (substr(abs.path,1,nchar('/usr/share/javascript/'))=='/usr/share/javascript/')
+ return(abs.path)
+ ## Debian specific hack for /usr/share/twitter-bootstrap symlinks
+ if (substr(abs.path,1,nchar('/usr/share/twitter-bootstrap/'))=='/usr/share/twitter-bootstrap/')
+ return(abs.path)
if (nchar(abs.path) <= nchar(dir) + 1)
return(NULL)
if (substr(abs.path, 1, nchar(dir)) != dir ||
|