File: INSTALL

package info (click to toggle)
read-edid 3.0.2-1
  • links: PTS, VCS
  • area: main
  • in suites: bullseye, sid
  • size: 176 kB
  • ctags: 151
  • sloc: ansic: 1,065; makefile: 22
file content (9 lines) | stat: -rw-r--r-- 622 bytes parent folder | download | duplicates (2)
1
2
3
4
5
6
7
8
9
read-edid is packaged using CMake. To install, simply run:

cmake . 

from the current directory. Use the options '-DCLASSICBUILD=OFF' or '-DI2CBUILD=OFF' to disable building of either the VBE interface or the I2C interface to get-edid, respectively. Use both to disable building get-edid entirely.

After CMake has completed, use 'make' and 'make install' to build and install the package. The latter command will most likely require root access to run.

A note: read-edid requires CMake 2.6 or greater, as well as the libx86 library (and related development packages on binary ditributions) if VBE usage is to be built.