1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49
|
export DEB_BUILD_MAINT_OPTIONS = hardening=+bindnow
export DEB_LDFLAGS_MAINT_APPEND = -Wl,--as-needed
export REMCTL_PROGRAM_CFLAGS = -fPIE
export REMCTL_PROGRAM_LDFLAGS = -fPIE
export REMCTL_PERL_FLAGS := --installdirs vendor --create_packlist 0
export REMCTL_PYTHON_INSTALL := --install-layout=deb
export REMCTL_PYTHON_VERSIONS := $(shell py3versions -s)
%:
dh $@ --with python3,ruby
override_dh_autoreconf:
dh_autoreconf --as-needed
override_dh_auto_configure:
dh_auto_configure -- PATH_SUDO=/usr/bin/sudo --sysconfdir=/etc/remctl \
--with-systemdsystemunitdir=/lib/systemd/system \
--enable-reduced-depends --enable-perl --enable-php \
--enable-python --enable-ruby
override_dh_install:
dh_install -Xlibremctl.la -Xusr/local/lib
dh_ruby --install
dh_php -pphp-remctl
override_dh_missing:
dh_missing --fail-missing
override_dh_makeshlibs:
dh_makeshlibs -V 'libremctl1 (>= 3.3)'
|