1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25
|
override_dh_auto_configure:
if [ ! -e setup.py ]; then sed -e "s/\@VERSION\@/$(shell dpkg-parsechangelog | grep Version: | cut -f2 -d' ' | cut -f1 -d- )/" -e 's/\@NAME\@/rhn/' setup.py.in > setup.py; fi
if [ ! -e setup.cfg ]; then sed 's/\@RELEASE\@/$(shell dpkg-parsechangelog | grep Version: | cut -f2 -d' ' | cut -f2 -d- )/' setup.cfg.in > setup.cfg; fi
dh_auto_configure --buildsystem=python_distutils
clean:
if [ -f setup.py ]; then dh $@ --with python2 --buildsystem=python_distutils; fi
rm -f setup.py setup.cfg
rm -rf build
%:
dh $@ --with python2 --buildsystem python_distutils
|