1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36
|
export DEB_BUILD_MAINT_OPTIONS = hardening=+all
export DEB_LDFLAGS_MAINT_APPEND = -Wl,-O1
%:
dh $@
ifneq ($(DEB_HOST_ARCH_OS),linux)
CONFFLAGS = --Dgudev=disabled
endif
override_dh_auto_configure:
dh_auto_configure -- \
-Dauto_features=enabled \
-Dgtk_doc=true \
-Dplugins_vala=disabled \
$(CONFFLAGS)
override_dh_auto_test:
xvfb-run dh_auto_test -- --timeout-multiplier 3
override_dh_missing:
dh_missing -Xrbzeitgeist
override_dh_python3:
dh_python3 --no-ext-rename /usr/lib/$(DEB_HOST_MULTIARCH)/rhythmbox
override_dh_makeshlibs:
dh_makeshlibs -prhythmbox-plugins --no-act
dh_makeshlibs -prhythmbox-plugin-cdrecorder --no-act
dh_makeshlibs --remaining-packages
|