1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130
|
PACKAGE:=rng-tools
PKGDIR:=$(CURDIR)/debian/$(PACKAGE)
export DH_ALWAYS_EXCLUDE=CVS:.svn:.git
DEB_BUILD_ARCH ?= $(shell dpkg-architecture -qDEB_BUILD_ARCH)
DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
ifneq (,$(findstring strict,$(DEB_BUILD_OPTIONS)))
CFLAGS += -Werror
endif
confflags=
ifeq ($(DEB_BUILD_GNU_TYPE), $(DEB_HOST_GNU_TYPE))
confflags += --build $(DEB_HOST_GNU_TYPE)
else
confflags += --build $(DEB_BUILD_GNU_TYPE) --host $(DEB_HOST_GNU_TYPE)
endif
ifneq (,$(findstring i386,$(DEB_BUILD_ARCH)))
confflags += --enable-viapadlock
endif
build-prepare: build-prepare-stamp
build-prepare-stamp:
@dh_testdir
./autogen.sh
touch build-prepare-stamp
configure-stamp: | build-prepare
dh_testdir
./configure CFLAGS="$(CFLAGS) -Wall -pipe" $(confflags)\
--prefix=/usr \
--mandir=\$${prefix}/share/man \
--infodir=\$${prefix}/share/info
touch configure-stamp
build: build-stamp
build-stamp: configure-stamp
dh_testdir
$(MAKE)
touch build-stamp
clean:
dh_testdir
dh_testroot
rm -f build-stamp configure-stamp
rm -rf autom4te.cache
[ ! -f Makefile ] || $(MAKE) distclean
rm -f config.sub config.guess configure config.log
rm -fr autom4te.cache
rm -f Makefile.in aclocal.m4 contrib/Makefile.in
rm -f Makefile contrib/Makefile
rm -f depcomp install-sh missing rng-tools-config.h.in
dh_clean
install: build
dh_testdir
dh_testroot
dh_prep
dh_installdirs
$(MAKE) install DESTDIR=$(PKGDIR)
mkdir -p $(PKGDIR)/etc/logcheck/ignore.d.server
install -m 644 debian/logcheck.ignore \
$(PKGDIR)/etc/logcheck/ignore.d.server/rng-tools
mkdir -p $(PKGDIR)/etc/logcheck/violations.ignore.d
install -m 644 debian/logcheck.ignore \
$(PKGDIR)/etc/logcheck/violations.ignore.d/rng-tools
binary-indep: build install
binary-arch: build install
dh_testdir
dh_testroot
dh_installdocs README
dh_installmodules
dh_installinit --error-handler=true
dh_installman
dh_installchangelogs ChangeLog
dh_lintian
dh_link
dh_strip
dh_compress
dh_fixperms
dh_installdeb
dh_shlibdeps
dh_gencontrol
dh_md5sums
dh_builddeb
binary: binary-indep binary-arch
.PHONY: build clean binary-indep binary-arch binary install build-prepare
|