1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63
|
export CXX=hipcc
export DEB_BUILD_MAINT_OPTIONS = hardening=+all optimize=-lto
export DEB_CXXFLAGS_MAINT_PREPEND = -gz
export VERBOSE=1
CXXFLAGS := $(subst -fstack-protector-strong,-Xarch_host -fstack-protector-strong,$(CXXFLAGS))
CXXFLAGS := $(subst -fcf-protection,-Xarch_host -fcf-protection,$(CXXFLAGS))
VERSION_STRING = $(shell sed -nr 's/^set.*VERSION_STRING \"([.0-9]+)\".*/\1/p' CMakeLists.txt)
CMAKE_FLAGS = \
-DCMAKE_BUILD_TYPE=Release \
-DAMDGPU_TARGETS="gfx803;gfx900;gfx906;gfx908;gfx90a;gfx1010;gfx1011;gfx1030;gfx1100;gfx1101;gfx1102" \
-DROCFFT_KERNEL_CACHE_ENABLE=OFF \
-DROCM_SYMLINK_LIBS=OFF \
-DBUILD_FILE_REORG_BACKWARD_COMPATIBILITY=OFF \
-DBUILD_CLIENTS_TESTS_OPENMP=OFF \
-DSQLITE_USE_SYSTEM_PACKAGE=ON
ifeq (,$(filter nocheck,$(DEB_BUILD_PROFILES)))
CMAKE_FLAGS += -DBUILD_CLIENTS_TESTS=ON
endif
%:
dh $@ -Scmake
override_dh_auto_configure-arch:
dh_auto_configure -- $(CMAKE_FLAGS)
override_dh_auto_test-arch:
ifeq (,$(filter nocheck,$(DEB_BUILD_OPTIONS)))
set -e \
; if [ -r /dev/kfd ] \
; then obj-$(DEB_HOST_MULTIARCH)/clients/staging/rocfft-test \
; else echo "W: /dev/kfd unreadable: no available AMD GPU." \
; echo "W: tests skipped." \
; fi
endif
execute_before_dh_install-arch:
dh_install -plibrocfft0 usr/lib/*/rocfft/${VERSION_STRING}/rocfft_rtc_helper
override_dh_auto_configure-indep:
:
override_dh_auto_build-indep:
ifeq (,$(filter nodoc,$(DEB_BUILD_OPTIONS)))
cd docs/.doxygen && doxygen
sphinx-build -b html docs html
endif
override_dh_auto_test-indep:
:
override_dh_auto_install-indep:
:
# dwz doesn't fully support DWARF-5 yet, see #1016936
override_dh_dwz:
:
|