1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21
|
export PYBUILD_NAME=rpi.gpio
export PYBUILD_DISABLE=test
export DEB_BUILD_MAINT_OPTIONS = hardening=+all
DEB_CFLAGS_MAINT_APPEND += $(shell getconf LFS_CFLAGS) -fcommon
DEB_LDFLAGS_MAINT_APPEND += $(shell getconf LFS_LDFLAGS)
DEB_LDFLAGS_MAINT_APPEND += -Wl,--as-needed
export DEB_CFLAGS_MAINT_APPEND DEB_LDFLAGS_MAINT_APPEND
include /usr/share/dpkg/default.mk
%:
dh $@ --with python3 --buildsystem=pybuild
override_dh_installdocs:
dh_installdocs --link-doc=rpi.gpio-common
|