File: .travis.yml

package info (click to toggle)
rpmlint 1.9-6
  • links: PTS, VCS
  • area: main
  • in suites: sid, stretch
  • size: 22,212 kB
  • ctags: 722
  • sloc: python: 14,926; makefile: 63; sh: 49
file content (30 lines) | stat: -rw-r--r-- 727 bytes parent folder | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
language: python

# python-rpm is not available through pip, so we get it with apt-get
# and configure the virtualenv to use system site packages. As long as
# that's the case, we need to stick with the system installed Python
# versions only. Unfortunately as python3-rpm is not available even
# for Trusty, that means 2.7 only for now.

dist: trusty

python:
  - "2.7"

virtualenv:
  system_site_packages: true

addons:
  apt:
    packages:
      - python-enchant
      - python-magic

install:
  # https://github.com/travis-ci/apt-package-whitelist/issues/1696
  - sudo apt-get update -qq
  - sudo apt-get install -qq python-rpm rpm rpm2cpio
  - pip install pytest flake8 flake8-import-order hacking

script:
  - make check