File: INSTALL

package info (click to toggle)
rpmlint 1.9-6
  • links: PTS, VCS
  • area: main
  • in suites: sid, stretch
  • size: 22,212 kB
  • ctags: 722
  • sloc: python: 14,926; makefile: 63; sh: 49
file content (19 lines) | stat: -rw-r--r-- 527 bytes parent folder | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
You need the following utilities to run rpmlint:

	o python 2.6 or newer
	o rpm 4.4.2.2 or newer and its python bindings
	o libmagic 5.05 and its python bindings (optional)
	o readelf
	o cpio
	o desktop-file-validate
	o gzip, bzip2 and xz
	o groff and gtbl (optional)
	o enchant and its python bindings (optional)
	o appstream-util, part of appstream-glib (optional)

and the following programs to install it:

	o python 2.6 or newer
	o rpm python bindings 4.4 or newer
	o sed
	o pytest and flake8 (for running the test suite)