File: changelog

package info (click to toggle)
rspamd 1.8.1-2
  • links: PTS, VCS
  • area: main
  • in suites: buster
  • size: 23,572 kB
  • sloc: ansic: 348,610; asm: 12,457; perl: 2,869; pascal: 1,532; cpp: 738; python: 653; java: 433; sh: 331; sql: 312; xml: 116; makefile: 111
file content (73 lines) | stat: -rw-r--r-- 2,640 bytes parent folder | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
rspamd (1.8.1-2) unstable; urgency=medium

  * d/control: Switch to libpcre2-dev (Closes: #911935)
  * d/rules:
    + Enable pcre2 support
    + Fix filter (gnu_cpu and filter architecture)

 -- Sebastien Badia <sbadia@debian.org>  Sat, 10 Nov 2018 22:58:51 +0100

rspamd (1.8.1-1) unstable; urgency=medium

  [ Jerome Lebleu ]
  * d/missing-sources: Add NProgress source
  * d/copyright:
    + Remove unused clauses
    + Update and add missing clauses for contrib/*
    + Correct some clauses license
    + Normalize licenses regarding Debian format
  * New upstream version 1.8.1 (Closes: #909619)

  [ Sebastien Badia ]
  * d/rules: Fix build on aarch64, mips64, ppc64le, parisc64, ia64, ppc64
    thanks @randomstuff and @alexAubin !
    refs: https://github.com/rspamd/rspamd/issues/2202#issuecomment-401545304

 -- Sebastien Badia <sbadia@debian.org>  Sat, 10 Nov 2018 15:19:42 +0100

rspamd (1.7.9-1) unstable; urgency=medium

  [ Sebastien Badia ]
  * d/rules: Enable libunwind support (upstream)
  * d/control:
    + Bump to Standards-Version 4.2.1 (no changes needed)
    + Switch Mikhail and me as Maintainer
  * d/patches: Fix wrong-path-for-interpreter (Perl interpreter)
  * New upstream version 1.7.9

  [ Jérôme Lebleu ]
  * d/scripts: Update require.min.js path coming with 1.7.7

 -- Sebastien Badia <sbadia@debian.org>  Thu, 06 Sep 2018 09:59:05 +0200

rspamd (1.7.6-1) unstable; urgency=medium

  [ Jerome Lebleu ]
  * d/source: Switch to 3.0 native to quilt source format
  * d/rules:
    + Enable hardening=+all (relro)
    + Rely on default rules for systemd and sysv service setup
    + Update configuration var. and fix permission on log dir
  * d/rspamd.init: Use rspamd.conf as config. file and test it on start

  [ Sebastien Badia ]
  * New upstream version 1.7.6 (Closes: #813222, #849396)
  * Added upstream-metadata-file (refs: http://dep.debian.net/deps/dep12/)
  * Depends on packaged js libs and import minified versions
  * d/man: Added a manpage for rspamd_stats
  * d/copyright: Update copyright years and use HTTPS for URI
  * d/control:
    + Use salsa.debian.org in Vcs-* fields
    + Bump to Standards-Version 4.1.4 (no changes needed)
    + Update Build-Depends according new upstream release
  * d/rules: Remove un-needed dh_systemd (it's now enabled by default)
  * d/compat: Bump compat version to 11
  * d/tests: Added a basic test suite (systemd + rspamd web)

 -- Sebastien Badia <sbadia@debian.org>  Sat, 23 Jun 2018 13:35:46 +0200

rspamd (0.6.10) unstable; urgency=low

  * Initial release (Closes: #683746)

 -- Mikhail Gusarov <dottedmag@debian.org>  Wed, 13 Aug 2014 00:28:21 +0200