File: acme-client.gemspec

package info (click to toggle)
ruby-acme-client 2.0.6-1~bpo10%2B1
  • links: PTS, VCS
  • area: main
  • in suites: buster-backports
  • size: 884 kB
  • sloc: ruby: 1,969; makefile: 6; sh: 3
file content (30 lines) | stat: -rw-r--r-- 1,095 bytes parent folder | download | duplicates (2)
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
lib = File.expand_path('../lib', __FILE__)
$LOAD_PATH.unshift(lib) unless $LOAD_PATH.include?(lib)
require 'acme/client/version'

Gem::Specification.new do |spec|
  spec.name          = 'acme-client'
  spec.version       = Acme::Client::VERSION
  spec.authors       = ['Charles Barbier']
  spec.email         = ['unixcharles@gmail.com']
  spec.summary       = 'Client for the ACME protocol.'
  spec.homepage      = 'http://github.com/unixcharles/acme-client'
  spec.license       = 'MIT'

  spec.files         = Dir.glob("**/*").select {|v| v !~ /^debian/}
  spec.require_paths = ['lib']

  spec.required_ruby_version = '>= 2.1.0'

  spec.add_development_dependency 'bundler', '>= 1.17.3'
  if Gem::Version.new(RUBY_VERSION) < Gem::Version.new('2.2')
    spec.add_development_dependency 'rake', '>= 12.0'
  else
    spec.add_development_dependency 'rake', '~> 13.0'
  end
  spec.add_development_dependency 'rspec', '~> 3.9'
  spec.add_development_dependency 'vcr', '~> 2.9'
  spec.add_development_dependency 'webmock', '~> 3.8'

  spec.add_runtime_dependency 'faraday', '>= 0.17', '< 2.0.0'
end