File: History.txt

package info (click to toggle)
ruby-acts-as-api 1.0.1-2
  • links: PTS, VCS
  • area: main
  • in suites: bullseye, buster, sid
  • size: 624 kB
  • sloc: ruby: 2,366; makefile: 2
file content (125 lines) | stat: -rw-r--r-- 2,581 bytes parent folder | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
=== 1.0.1 2017-08-04

* Updates spec suite to Rails 5.1.3

=== 1.0.0 2016-11-24

* Ditch Ruby 1.8 syntax, overall modernization
* Finally, 1.0!

=== 0.4.4 2016-11-09

* Updates spec suite to Rails 5

=== 0.4.3 2016-07-31

* Sets correct content type for JSONP responses (see PR #98)

=== 0.4.2 2013-12-28

* Fixed problem with rendering of POROs (see PR #88)

=== 0.4.1 2012-07-18

* Added support for Mongoid 3

=== 0.4 2012-04-30

* Added support for a second parameter (options) to pass to as_api_response

=== 0.3.11 2011-11-06

* Added :postfix, :prefix options for template rendering

=== 0.3.10 2011-10-03

* Fixed Mongoid problems, when no ActiveRecord is available (Ticket #36)

=== 0.3.9 2011-09-24

* Spec suite now running on Rails 3.1
* Fixed naming issue with ActiveRecord::Relation (Ticket #35)

=== 0.3.8 2011-06-21

* Fixed Rails 3.1 deprecation warning

=== 0.3.7 2011-06-13

* Added before/around/after callbacks

=== 0.3.6 2011-05-13

* Finally added Mongoid Support out of the box
* Support for Rails 3 Responders

=== 0.3.4 2011-04-26

* Fixed a bug concerning the inheritance of sub templates/additional options

=== 0.3.3 2011-04-24

* Added support for :if and :unless options

=== 0.3.2 2011-04-20

* Raise an exception if a specified api template is not found

=== 0.3.1 2011-04-08

* Added the :template option to specify sub templates

* Fixed a bug concerning extended api templates

=== 0.3.0 2011-02-22

* Added bundler support

* Added mongoid support

* Removed lots of unnecessary dependencies esp. ActiveRecord

=== 0.2.2 2010-10-21

* Version bump only for changing the github account in the docs.

=== 0.2.1 2010-09-20

* Updated to work with Rails 3.0.0

* Added support for multiple renderings of the same model (e.g. useful for versioning).
  Note that the interface of acts as api changed, soyou have to update your code.

* Updated dependecies to user Rails 3.0.0 libs instead of beta.

=== 0.1.10 2010-07-23

* More Bugfixes. When you want to render an Array of records (e.g. from MyRecord.all)
make sure you pass the :root options to render_as_api - in case it will return an empty array

=== 0.1.7 2010-07-05

* Fixed bug with multi-word models.

=== 0.1.4 2010-07-04

* Added better documentation.

=== 0.1.3 2010-07-04

* Support for including methods of associated models.
* Better root name determination for arrays.

=== 0.0.3 2010-07-01

* 1 small bugfix

=== 0.0.2 2010-07-01

* 1 major enhancement:
  * Added a wrapping root node for JSON responses by default.

=== 0.0.1 2010-06-27

* 1 major enhancement:
  * Initial release