1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36
|
Source: ruby-ast
Section: ruby
Priority: optional
Maintainer: Debian Ruby Team <pkg-ruby-extras-maintainers@lists.alioth.debian.org>
Uploaders: Miguel Landaeta <nomadium@debian.org>,
Utkarsh Gupta <utkarsh@debian.org>
Build-Depends: debhelper-compat (= 13),
gem2deb,
rake,
ruby-bacon,
ruby-coveralls,
ruby-simplecov
Standards-Version: 4.6.2
Vcs-Git: https://salsa.debian.org/ruby-team/ruby-ast.git
Vcs-Browser: https://salsa.debian.org/ruby-team/ruby-ast
Homepage: https://whitequark.github.io/ast/
Testsuite: autopkgtest-pkg-ruby
Rules-Requires-Root: no
Package: ruby-ast
Architecture: all
Depends: ${misc:Depends},
${ruby:Depends},
${shlibs:Depends}
Multi-Arch: foreign
Description: Ruby library for working with abstract syntax trees
ast embraces immutability; each AST node is inherently frozen at
creation, and updating a child node requires recreating that node
and its every parent, recursively.
.
This is a design choice. It does create some pressure on
garbage collector, but completely eliminates all concurrency
and aliasing problems.
.
See also AST::Node, AST::Processor::Mixin and AST::Sexp classes for
additional recommendations and design patterns.
|