File: attr_required.gemspec

package info (click to toggle)
ruby-attr-required 1.0.0-2.1
  • links: PTS, VCS
  • area: main
  • in suites: bullseye, sid
  • size: 160 kB
  • sloc: ruby: 290; makefile: 2
file content (20 lines) | stat: -rw-r--r-- 886 bytes parent folder | download | duplicates (2)
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
Gem::Specification.new do |s|
  s.name = "attr_required"
  s.version = File.read("VERSION")
  s.required_rubygems_version = Gem::Requirement.new(">= 1.3.6") if s.respond_to? :required_rubygems_version=
  s.authors = ["nov matake"]
  s.description = %q{attr_required and attr_optional}
  s.summary = %q{attr_required and attr_optional}
  s.email = "nov@matake.jp"
  s.extra_rdoc_files = ["LICENSE", "README.rdoc"]
  s.license = 'MIT'
  s.rdoc_options = ["--charset=UTF-8"]
  s.homepage = "http://github.com/nov/attr_required"
  s.require_paths = ["lib"]
  s.executables = `git ls-files -- bin/*`.split("\n").map{ |f| File.basename(f) }
  s.files = `git ls-files`.split("\n")
  s.test_files = `git ls-files -- {test,spec,features}/*`.split("\n")
  s.add_development_dependency "rake", ">= 0.8"
  s.add_development_dependency "simplecov"
  s.add_development_dependency "rspec", ">= 2"
end