File: metadata.yml

package info (click to toggle)
ruby-attr-required 1.0.0-2.1
  • links: PTS, VCS
  • area: main
  • in suites: bullseye, sid
  • size: 160 kB
  • sloc: ruby: 290; makefile: 2
file content (105 lines) | stat: -rw-r--r-- 2,355 bytes parent folder | download | duplicates (2)
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
--- !ruby/object:Gem::Specification
name: attr_required
version: !ruby/object:Gem::Version
  version: 1.0.0
platform: ruby
authors:
- nov matake
autorequire: 
bindir: bin
cert_chain: []
date: 2014-01-29 00:00:00.000000000 Z
dependencies:
- !ruby/object:Gem::Dependency
  name: rake
  requirement: !ruby/object:Gem::Requirement
    requirements:
    - - '>='
      - !ruby/object:Gem::Version
        version: '0.8'
  type: :development
  prerelease: false
  version_requirements: !ruby/object:Gem::Requirement
    requirements:
    - - '>='
      - !ruby/object:Gem::Version
        version: '0.8'
- !ruby/object:Gem::Dependency
  name: simplecov
  requirement: !ruby/object:Gem::Requirement
    requirements:
    - - '>='
      - !ruby/object:Gem::Version
        version: '0'
  type: :development
  prerelease: false
  version_requirements: !ruby/object:Gem::Requirement
    requirements:
    - - '>='
      - !ruby/object:Gem::Version
        version: '0'
- !ruby/object:Gem::Dependency
  name: rspec
  requirement: !ruby/object:Gem::Requirement
    requirements:
    - - '>='
      - !ruby/object:Gem::Version
        version: '2'
  type: :development
  prerelease: false
  version_requirements: !ruby/object:Gem::Requirement
    requirements:
    - - '>='
      - !ruby/object:Gem::Version
        version: '2'
description: attr_required and attr_optional
email: nov@matake.jp
executables: []
extensions: []
extra_rdoc_files:
- LICENSE
- README.rdoc
files:
- .gitignore
- .rspec
- .travis.yml
- Gemfile
- LICENSE
- README.rdoc
- Rakefile
- VERSION
- attr_required.gemspec
- lib/attr_optional.rb
- lib/attr_required.rb
- spec/attr_optional_spec.rb
- spec/attr_required_spec.rb
- spec/spec_helper.rb
homepage: http://github.com/nov/attr_required
licenses:
- MIT
metadata: {}
post_install_message: 
rdoc_options:
- --charset=UTF-8
require_paths:
- lib
required_ruby_version: !ruby/object:Gem::Requirement
  requirements:
  - - '>='
    - !ruby/object:Gem::Version
      version: '0'
required_rubygems_version: !ruby/object:Gem::Requirement
  requirements:
  - - '>='
    - !ruby/object:Gem::Version
      version: 1.3.6
requirements: []
rubyforge_project: 
rubygems_version: 2.0.3
signing_key: 
specification_version: 4
summary: attr_required and attr_optional
test_files:
- spec/attr_optional_spec.rb
- spec/attr_required_spec.rb
- spec/spec_helper.rb