File: rules

package info (click to toggle)
ruby-barby 0.6.8+dfsg-1
  • links: PTS, VCS
  • area: main
  • in suites: bullseye, sid
  • size: 484 kB
  • sloc: ruby: 4,169; java: 1,228; makefile: 7
file content (14 lines) | stat: -rwxr-xr-x 409 bytes parent folder | download | duplicates (3)
1
2
3
4
5
6
7
8
9
10
11
12
13
14
#!/usr/bin/make -f

export GEM2DEB_TEST_RUNNER = --check-dependencies

%:
	dh $@ --buildsystem=ruby --with ruby

override_dh_install:
	dh_install
	# Exclude the sample binary /usr/bin/barby - it is not really useful,
	# and it is mostly buggy.
	$(RM) -r debian/ruby-barby/usr/bin
	# Exclude PDF417 functionality, as it requires JRuby
	$(RM) debian/ruby-barby/usr/lib/ruby/vendor_ruby/barby/barcode/pdf_417.rb