File: batch-loader.gemspec

package info (click to toggle)
ruby-batch-loader 1.4.1+dfsg.1-3
  • links: PTS, VCS
  • area: main
  • in suites: bullseye, sid
  • size: 264 kB
  • sloc: ruby: 760; makefile: 5; sh: 4
file content (31 lines) | stat: -rw-r--r-- 1,180 bytes parent folder | download | duplicates (2)
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
# coding: utf-8
require_relative "./lib/batch_loader/version"

Gem::Specification.new do |spec|
  spec.name          = "batch-loader"
  spec.version       = BatchLoader::VERSION
  spec.authors       = ["exAspArk"]
  spec.email         = ["exaspark@gmail.com"]

  spec.summary       = %q{Powerful tool to avoid N+1 DB or HTTP queries}
  spec.description   = %q{Powerful tool to avoid N+1 DB or HTTP queries}
  spec.homepage      = "https://github.com/exAspArk/batch-loader"
  spec.license       = "MIT"

  spec.files         = Dir.glob('**/*').reject do |f|
    f.match(%r{^(spec|images)/})
  end
  spec.bindir        = "exe"
  spec.executables   = spec.files.grep(%r{^exe/}) { |f| File.basename(f) }
  spec.require_paths = ["lib"]

  spec.required_ruby_version = '>= 2.1.0' # keyword args

  spec.add_development_dependency "bundler", "~> 2.0"
  spec.add_development_dependency "rake", "~> 10.0"
  spec.add_development_dependency "rspec", "~> 3.0"
  spec.add_development_dependency "graphql", "~> 1.6"
  spec.add_development_dependency "pry-byebug", "~> 3.4"
  spec.add_development_dependency "benchmark-ips", "~> 2.7"
  spec.add_development_dependency "ruby-prof", "~> 0.16"
end