File: metadata.yml

package info (click to toggle)
ruby-beaneater 1.0.0-1
  • links: PTS, VCS
  • area: main
  • in suites: bullseye, buster, sid, stretch
  • size: 276 kB
  • ctags: 132
  • sloc: ruby: 1,602; sh: 4; makefile: 2
file content (162 lines) | stat: -rw-r--r-- 3,763 bytes parent folder | download | duplicates (2)
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
135
136
137
138
139
140
141
142
143
144
145
146
147
148
149
150
151
152
153
154
155
156
157
158
159
160
161
162
--- !ruby/object:Gem::Specification
name: beaneater
version: !ruby/object:Gem::Version
  version: 1.0.0
platform: ruby
authors:
- Nico Taing
autorequire: 
bindir: bin
cert_chain: []
date: 2015-04-26 00:00:00.000000000 Z
dependencies:
- !ruby/object:Gem::Dependency
  name: minitest
  requirement: !ruby/object:Gem::Requirement
    requirements:
    - - ~>
      - !ruby/object:Gem::Version
        version: 4.1.0
  type: :development
  prerelease: false
  version_requirements: !ruby/object:Gem::Requirement
    requirements:
    - - ~>
      - !ruby/object:Gem::Version
        version: 4.1.0
- !ruby/object:Gem::Dependency
  name: rake
  requirement: !ruby/object:Gem::Requirement
    requirements:
    - - '>='
      - !ruby/object:Gem::Version
        version: '0'
  type: :development
  prerelease: false
  version_requirements: !ruby/object:Gem::Requirement
    requirements:
    - - '>='
      - !ruby/object:Gem::Version
        version: '0'
- !ruby/object:Gem::Dependency
  name: mocha
  requirement: !ruby/object:Gem::Requirement
    requirements:
    - - '>='
      - !ruby/object:Gem::Version
        version: '0'
  type: :development
  prerelease: false
  version_requirements: !ruby/object:Gem::Requirement
    requirements:
    - - '>='
      - !ruby/object:Gem::Version
        version: '0'
- !ruby/object:Gem::Dependency
  name: term-ansicolor
  requirement: !ruby/object:Gem::Requirement
    requirements:
    - - '>='
      - !ruby/object:Gem::Version
        version: '0'
  type: :development
  prerelease: false
  version_requirements: !ruby/object:Gem::Requirement
    requirements:
    - - '>='
      - !ruby/object:Gem::Version
        version: '0'
- !ruby/object:Gem::Dependency
  name: json
  requirement: !ruby/object:Gem::Requirement
    requirements:
    - - '>='
      - !ruby/object:Gem::Version
        version: '0'
  type: :development
  prerelease: false
  version_requirements: !ruby/object:Gem::Requirement
    requirements:
    - - '>='
      - !ruby/object:Gem::Version
        version: '0'
description: Simple beanstalkd client for ruby
email:
- nico.taing@gmail.com
executables: []
extensions: []
extra_rdoc_files: []
files:
- .gitignore
- .travis.yml
- .yardopts
- CHANGELOG.md
- Gemfile
- LICENSE.txt
- README.md
- Rakefile
- TODO
- beaneater.gemspec
- examples/demo.rb
- lib/beaneater.rb
- lib/beaneater/configuration.rb
- lib/beaneater/connection.rb
- lib/beaneater/errors.rb
- lib/beaneater/job.rb
- lib/beaneater/job/collection.rb
- lib/beaneater/job/record.rb
- lib/beaneater/stats.rb
- lib/beaneater/stats/fast_struct.rb
- lib/beaneater/stats/stat_struct.rb
- lib/beaneater/tube.rb
- lib/beaneater/tube/collection.rb
- lib/beaneater/tube/record.rb
- lib/beaneater/version.rb
- test/beaneater_test.rb
- test/connection_test.rb
- test/errors_test.rb
- test/job_test.rb
- test/jobs_test.rb
- test/prompt_regexp_test.rb
- test/stat_struct_test.rb
- test/stats_test.rb
- test/test_helper.rb
- test/tube_test.rb
- test/tubes_test.rb
homepage: ''
licenses:
- MIT
metadata: {}
post_install_message: 
rdoc_options: []
require_paths:
- lib
required_ruby_version: !ruby/object:Gem::Requirement
  requirements:
  - - '>='
    - !ruby/object:Gem::Version
      version: '0'
required_rubygems_version: !ruby/object:Gem::Requirement
  requirements:
  - - '>='
    - !ruby/object:Gem::Version
      version: '0'
requirements: []
rubyforge_project: 
rubygems_version: 2.0.6
signing_key: 
specification_version: 4
summary: Simple beanstalkd client for ruby.
test_files:
- test/beaneater_test.rb
- test/connection_test.rb
- test/errors_test.rb
- test/job_test.rb
- test/jobs_test.rb
- test/prompt_regexp_test.rb
- test/stat_struct_test.rb
- test/stats_test.rb
- test/test_helper.rb
- test/tube_test.rb
- test/tubes_test.rb
has_rdoc: