File: changelog

package info (click to toggle)
ruby-bson 4.3.0-1
  • links: PTS, VCS
  • area: main
  • in suites: buster, sid
  • size: 900 kB
  • sloc: ruby: 6,019; ansic: 1,028; makefile: 5
file content (118 lines) | stat: -rw-r--r-- 3,748 bytes parent folder | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
ruby-bson (4.3.0-1) unstable; urgency=medium

  * New upstream version 4.3.0
  * Drop d/patches
  * Bump Standards-Version to 4.1.3; no changes needed
  * Switch Vcs-* URLs to salsa.d.o
  * d/copyright: adjust years
  * d/control: switch Homepage to https://
  * d/control: convert Priority: extra to optional
  * Bump dh compat to 11; no changes needed
  * d/watch: switch URL to Github and handle betas
  * Add d/ruby-tests.rake
    + B-D on ruby-rspec
  * Enable autopkgtests using gem2deb-test-runner

 -- Apollon Oikonomopoulos <apoikos@debian.org>  Fri, 30 Mar 2018 00:29:43 +0300

ruby-bson (4.2.1-1) unstable; urgency=medium

  * New upstream release

 -- Apollon Oikonomopoulos <apoikos@debian.org>  Wed, 21 Dec 2016 14:49:17 +0200

ruby-bson (4.2.0-2) unstable; urgency=medium

  * Drop unneeded build-dependencies:
    + ruby-activesupport
    + ruby-mocha
    + ruby-shoulda

 -- Apollon Oikonomopoulos <apoikos@debian.org>  Tue, 20 Dec 2016 14:15:34 +0200

ruby-bson (4.2.0-1) unstable; urgency=medium

  [ Cédric Boutillier ]
  * Bump debhelper compatibility level to 9
  * Remove version in the gem2deb build-dependency
  * Use https:// in Vcs-* fields
  * Use https:// in Vcs-* fields
  * Bump Standards-Version to 3.9.7 (no changes needed)
  * Run wrap-and-sort on packaging files

  [ Apollon Oikonomopoulos ]
  * New upstream version 4.2.0
    + Supports MongoDB server versions up to (and including) 3.4
  * Drop patches merged upstream:
    + Update_BSON_ObjectId_validation.patch
    + remove_rubygems_from_bins.patch
  * Drop ruby-bson.examples; not shipped upstream since 2.x
  * Bump Standards to 3.9.8; no changes needed
  * Take over ruby-bson-ext and ship the native extension in ruby-bson. The
    native extension is now built by this very source and is required by
    ruby-bson.
    + Mark the ruby-bson package as arch: any
    + Provide a dummy transitional package for ruby-bson-ext
  * Add myself to Uploaders

 -- Apollon Oikonomopoulos <apoikos@debian.org>  Tue, 20 Dec 2016 12:41:34 +0200

ruby-bson (1.10.0-2) unstable; urgency=medium

  * Fix CVE-2015-4410: DoS and possible injection (Closes: #787951)

 -- Prach Pongpanich <prachpub@gmail.com>  Sun, 15 Nov 2015 12:15:48 +0700

ruby-bson (1.10.0-1) unstable; urgency=medium

  [ Cédric Boutillier ]
  * The upstream copyright holder is now MongoDB Inc.
  * Bump Standards-Version to 3.9.5 (no changes needed)

  [ Prach Pongpanich ]
  * Imported Upstream version 1.10.0 (Closes: #747739)

 -- Prach Pongpanich <prachpub@gmail.com>  Thu, 15 May 2014 09:33:18 +0700

ruby-bson (1.9.2-1) unstable; urgency=low

  * Imported Upstream version 1.9.2

 -- Prach Pongpanich <prachpub@gmail.com>  Thu, 05 Sep 2013 11:47:16 +0700

ruby-bson (1.9.1-1) unstable; urgency=low

  * New upstream version

 -- Prach Pongpanich <prachpub@gmail.com>  Fri, 12 Jul 2013 19:47:57 +0700

ruby-bson (1.9.0-1) unstable; urgency=low

  * New upstream version
  * Remove debian/source/local-options, unapply-patches are default
    in dpkg-source since 1.16.1
  * Refreshed d/patches/remove_rubygems_from_bins.patch
  * Add myself as uploaders

 -- Prach Pongpanich <prachpub@gmail.com>  Tue, 11 Jun 2013 21:26:14 +0700

ruby-bson (1.8.5-2) unstable; urgency=low

  * Recommend ruby-bson-ext 

 -- Cédric Boutillier <boutil@debian.org>  Mon, 13 May 2013 15:08:05 +0200

ruby-bson (1.8.5-1) unstable; urgency=low

  * New upstream version
    + tests dropped from the gem version
  * drop debian/ruby-tests.rb
  * deactivate patches for tests

 -- Cédric Boutillier <boutil@debian.org>  Mon, 13 May 2013 13:38:27 +0200

ruby-bson (1.8.3-1) unstable; urgency=low

  * Initial release (Closes: #703530)

 -- Cédric Boutillier <boutil@debian.org>  Fri, 08 Mar 2013 15:28:28 +0100