File: buff-config.gemspec

package info (click to toggle)
ruby-buff-config 2.0.0-2
  • links: PTS, VCS
  • area: main
  • in suites: bullseye, buster, sid
  • size: 200 kB
  • sloc: ruby: 481; makefile: 3
file content (36 lines) | stat: -rw-r--r-- 1,426 bytes parent folder | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
# coding: utf-8
lib = File.expand_path('../lib', __FILE__)
$LOAD_PATH.unshift(lib) unless $LOAD_PATH.include?(lib)
require 'buff/config/version'

Gem::Specification.new do |spec|
  spec.name          = "buff-config"
  spec.version       = Buff::Config::VERSION
  spec.authors       = ["Jamie Winsor", "Kyle Allan"]
  spec.email         = ["jamie@vialstudios.com", "kallan@riotgames.com"]
  spec.description   = %q{A simple configuration class}
  spec.summary       = spec.description
  spec.homepage      = "https://github.com/RiotGames/buff-config"
  spec.license       = "Apache 2.0"

  spec.files         = `git ls-files`.split($/)
  spec.executables   = spec.files.grep(%r{^bin/}) { |f| File.basename(f) }
  spec.test_files    = spec.files.grep(%r{^spec/})
  spec.require_paths = ["lib"]
  spec.required_ruby_version = ">= 2.2.0"

  spec.add_dependency "varia_model", "~> 0.6"
  spec.add_dependency "buff-extensions", "~> 2.0"

  spec.add_development_dependency "buff-ruby_engine"
  spec.add_development_dependency "thor"
  spec.add_development_dependency "bundler"
  spec.add_development_dependency "rake"
  spec.add_development_dependency "rspec"
  spec.add_development_dependency "fuubar"
  spec.add_development_dependency "guard"
  spec.add_development_dependency "guard-rspec"
  spec.add_development_dependency "guard-spork"
  spec.add_development_dependency "spork"
  spec.add_development_dependency "json_spec"
end