File: metadata.yml

package info (click to toggle)
ruby-clamp 0.6.3-1
  • links: PTS, VCS
  • area: main
  • in suites: jessie, jessie-kfreebsd
  • size: 280 kB
  • ctags: 189
  • sloc: ruby: 2,071; makefile: 4
file content (94 lines) | stat: -rw-r--r-- 2,255 bytes parent folder | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
--- !ruby/object:Gem::Specification
name: clamp
version: !ruby/object:Gem::Version
  version: 0.6.3
platform: ruby
authors:
- Mike Williams
autorequire: 
bindir: bin
cert_chain: []
date: 2013-11-14 00:00:00.000000000 Z
dependencies: []
description: ! 'Clamp provides an object-model for command-line utilities.

  It handles parsing of command-line options, and generation of usage help.

'
email: mdub@dogbiscuit.org
executables: []
extensions: []
extra_rdoc_files: []
files:
- .autotest
- .gitignore
- .rspec
- .travis.yml
- CHANGES.md
- Gemfile
- LICENSE
- README.md
- Rakefile
- clamp.gemspec
- examples/admin
- examples/flipflop
- examples/fubar
- examples/gitdown
- examples/scoop
- examples/speak
- lib/clamp.rb
- lib/clamp/attribute/declaration.rb
- lib/clamp/attribute/definition.rb
- lib/clamp/attribute/instance.rb
- lib/clamp/command.rb
- lib/clamp/errors.rb
- lib/clamp/help.rb
- lib/clamp/option/declaration.rb
- lib/clamp/option/definition.rb
- lib/clamp/option/parsing.rb
- lib/clamp/parameter/declaration.rb
- lib/clamp/parameter/definition.rb
- lib/clamp/parameter/parsing.rb
- lib/clamp/subcommand/declaration.rb
- lib/clamp/subcommand/definition.rb
- lib/clamp/subcommand/execution.rb
- lib/clamp/subcommand/parsing.rb
- lib/clamp/truthy.rb
- lib/clamp/version.rb
- spec/clamp/command_group_spec.rb
- spec/clamp/command_spec.rb
- spec/clamp/option/definition_spec.rb
- spec/clamp/option_module_spec.rb
- spec/clamp/parameter/definition_spec.rb
- spec/spec_helper.rb
homepage: http://github.com/mdub/clamp
licenses:
- MIT
metadata: {}
post_install_message: 
rdoc_options: []
require_paths:
- lib
required_ruby_version: !ruby/object:Gem::Requirement
  requirements:
  - - ! '>='
    - !ruby/object:Gem::Version
      version: '0'
required_rubygems_version: !ruby/object:Gem::Requirement
  requirements:
  - - ! '>='
    - !ruby/object:Gem::Version
      version: '0'
requirements: []
rubyforge_project: 
rubygems_version: 2.0.7
signing_key: 
specification_version: 4
summary: a minimal framework for command-line utilities
test_files:
- spec/clamp/command_group_spec.rb
- spec/clamp/command_spec.rb
- spec/clamp/option/definition_spec.rb
- spec/clamp/option_module_spec.rb
- spec/clamp/parameter/definition_spec.rb
- spec/spec_helper.rb