File: coveralls-ruby.gemspec

package info (click to toggle)
ruby-coveralls 0.8.22-2
  • links: PTS, VCS
  • area: main
  • in suites: bullseye, sid
  • size: 260 kB
  • sloc: ruby: 1,218; makefile: 8
file content (28 lines) | stat: -rw-r--r-- 1,068 bytes parent folder | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
lib = File.expand_path('../lib', __FILE__)
$LOAD_PATH.unshift(lib) unless $LOAD_PATH.include?(lib)
require 'coveralls/version'

Gem::Specification.new do |gem|
  gem.authors       = ["Nick Merwin", "Wil Gieseler"]
  gem.email         = ["nick@lemurheavy.com", "supapuerco@gmail.com"]
  gem.description   = "A Ruby implementation of the Coveralls API."
  gem.summary       = "A Ruby implementation of the Coveralls API."
  gem.homepage      = "https://coveralls.io"
  gem.license       = "MIT"

  gem.files         = `git ls-files`.split($\)
  gem.executables   = gem.files.grep(%r{^bin/}).map{ |f| File.basename(f) }
  gem.test_files    = gem.files.grep(%r{^(test|spec|features)/})
  gem.name          = "coveralls"
  gem.require_paths = ["lib"]
  gem.version       = Coveralls::VERSION

  gem.required_ruby_version = '>= 1.8.7'

  gem.add_dependency 'json', '>= 1.8', '< 3'
  gem.add_dependency 'simplecov', '~> 0.16.1'
  gem.add_dependency 'term-ansicolor', '~> 1.3'
  gem.add_dependency 'thor', '~> 0.19.4'

  gem.add_development_dependency 'bundler', '~> 1.7'
end