File: metadata.yml

package info (click to toggle)
ruby-default-value-for 3.0.1-1
  • links: PTS, VCS
  • area: main
  • in suites: stretch
  • size: 144 kB
  • ctags: 97
  • sloc: ruby: 450; makefile: 2
file content (134 lines) | stat: -rw-r--r-- 3,330 bytes parent folder | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
--- !ruby/object:Gem::Specification
name: default_value_for
version: !ruby/object:Gem::Version
  version: 3.0.1
platform: ruby
authors:
- Hongli Lai
autorequire: 
bindir: bin
cert_chain: []
date: 2014-12-23 00:00:00.000000000 Z
dependencies:
- !ruby/object:Gem::Dependency
  name: activerecord
  requirement: !ruby/object:Gem::Requirement
    requirements:
    - - ! '>='
      - !ruby/object:Gem::Version
        version: 3.2.0
    - - <
      - !ruby/object:Gem::Version
        version: '5.0'
  type: :runtime
  prerelease: false
  version_requirements: !ruby/object:Gem::Requirement
    requirements:
    - - ! '>='
      - !ruby/object:Gem::Version
        version: 3.2.0
    - - <
      - !ruby/object:Gem::Version
        version: '5.0'
- !ruby/object:Gem::Dependency
  name: railties
  requirement: !ruby/object:Gem::Requirement
    requirements:
    - - ! '>='
      - !ruby/object:Gem::Version
        version: 3.2.0
    - - <
      - !ruby/object:Gem::Version
        version: '5.0'
  type: :development
  prerelease: false
  version_requirements: !ruby/object:Gem::Requirement
    requirements:
    - - ! '>='
      - !ruby/object:Gem::Version
        version: 3.2.0
    - - <
      - !ruby/object:Gem::Version
        version: '5.0'
- !ruby/object:Gem::Dependency
  name: minitest
  requirement: !ruby/object:Gem::Requirement
    requirements:
    - - ! '>='
      - !ruby/object:Gem::Version
        version: '4.2'
  type: :development
  prerelease: false
  version_requirements: !ruby/object:Gem::Requirement
    requirements:
    - - ! '>='
      - !ruby/object:Gem::Version
        version: '4.2'
- !ruby/object:Gem::Dependency
  name: minitest-around
  requirement: !ruby/object:Gem::Requirement
    requirements:
    - - ! '>='
      - !ruby/object:Gem::Version
        version: '0'
  type: :development
  prerelease: false
  version_requirements: !ruby/object:Gem::Requirement
    requirements:
    - - ! '>='
      - !ruby/object:Gem::Version
        version: '0'
- !ruby/object:Gem::Dependency
  name: appraisal
  requirement: !ruby/object:Gem::Requirement
    requirements:
    - - ! '>='
      - !ruby/object:Gem::Version
        version: '0'
  type: :development
  prerelease: false
  version_requirements: !ruby/object:Gem::Requirement
    requirements:
    - - ! '>='
      - !ruby/object:Gem::Version
        version: '0'
description: The default_value_for plugin allows one to define default values for
  ActiveRecord models in a declarative manner
email: software-signing@phusion.nl
executables: []
extensions: []
extra_rdoc_files: []
files:
- LICENSE.TXT
- README.md
- Rakefile
- default_value_for.gemspec
- init.rb
- lib/default_value_for.rb
- lib/default_value_for/railtie.rb
- test.rb
homepage: https://github.com/FooBarWidget/default_value_for
licenses:
- MIT
metadata: {}
post_install_message: 
rdoc_options: []
require_paths:
- lib
required_ruby_version: !ruby/object:Gem::Requirement
  requirements:
  - - ! '>='
    - !ruby/object:Gem::Version
      version: 1.9.3
required_rubygems_version: !ruby/object:Gem::Requirement
  requirements:
  - - ! '>='
    - !ruby/object:Gem::Version
      version: '0'
requirements: []
rubyforge_project: 
rubygems_version: 2.2.2
signing_key: 
specification_version: 4
summary: Provides a way to specify default values for ActiveRecord models
test_files: []