File: .travis.yml

package info (click to toggle)
ruby-delayed-job-active-record 4.1.4-1
  • links: PTS, VCS
  • area: main
  • in suites: bullseye, sid
  • size: 308 kB
  • sloc: ruby: 422; makefile: 5
file content (150 lines) | stat: -rw-r--r-- 4,049 bytes parent folder | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
135
136
137
138
139
140
141
142
143
144
145
146
147
148
149
150
language: ruby
branches:
  only:
    - master
services:
  - mysql
  - postgresql
addons:
  postgresql: '9.6'
before_script:
  - mysql -e 'create database delayed_job_test;'
  - mysql --version
  - psql -c 'create database delayed_job_test;' -U postgres
script: bundle exec $COMMAND
env:
  global:
    - JRUBY_OPTS="$JRUBY_OPTS -Xcli.debug=true --debug"
    - COMMAND=rspec
gemfile: # Supported
  - gemfiles/mysql2/4-2.gemfile
  - gemfiles/mysql2/5-1.gemfile
  - gemfiles/mysql2/5-2.gemfile
  - gemfiles/mysql2/6-0.gemfile
  - gemfiles/postgresql/4-2.gemfile
  - gemfiles/postgresql/5-1.gemfile
  - gemfiles/postgresql/5-2.gemfile
  - gemfiles/postgresql/6-0.gemfile
  - gemfiles/sqlite3/4-2.gemfile
  - gemfiles/sqlite3/5-1.gemfile
  - gemfiles/sqlite3/5-2.gemfile
  - gemfiles/sqlite3/6-0.gemfile
rvm: # Supported
  - 2.3.8
  - 2.4.6
  - 2.5.5
  - 2.6.3
  - jruby-9.2.7.0

jdk: oraclejdk11

matrix:
  allow_failures:
    - rvm: jruby-head # Future
    - rvm: rbx-2 # Parallel dimension
    - rvm: ruby-head # Future
    - gemfile: gemfiles/mysql2/master.gemfile # Future
    - gemfile: gemfiles/postgresql/master.gemfile # Future
    - gemfile: gemfiles/sqlite3/master.gemfile # Future

  exclude:
    - gemfile: gemfiles/mysql2/6-0.gemfile
      rvm: 2.3.8
    - gemfile: gemfiles/mysql2/6-0.gemfile
      rvm: 2.4.6
    - gemfile: gemfiles/postgresql/6-0.gemfile
      rvm: 2.3.8
    - gemfile: gemfiles/postgresql/6-0.gemfile
      rvm: 2.4.6
    - gemfile: gemfiles/sqlite3/6-0.gemfile
      rvm: 2.3.8
    - gemfile: gemfiles/sqlite3/6-0.gemfile
      rvm: 2.4.6

  include:
    #
    # Rubocop
    #
    - rvm: 2.5.5
      gemfile: Gemfile
      env:
        - COMMAND=rubocop
    #
    # The future
    #
    # Active Record head
    - rvm: 2.5.5
      gemfile: gemfiles/mysql2/master.gemfile
    - rvm: 2.5.5
      gemfile: gemfiles/postgresql/master.gemfile
    - rvm: 2.5.5
      gemfile: gemfiles/sqlite3/master.gemfile
    - rvm: 2.6.3
      gemfile: gemfiles/mysql2/master.gemfile
    - rvm: 2.6.3
      gemfile: gemfiles/postgresql/master.gemfile
    - rvm: 2.6.3
      gemfile: gemfiles/sqlite3/master.gemfile
    # MRI Ruby head
    - rvm: ruby-head
      gemfile: gemfiles/mysql2/5-2.gemfile
    - rvm: ruby-head
      gemfile: gemfiles/postgresql/5-2.gemfile
    - rvm: ruby-head
      gemfile: gemfiles/sqlite3/5-2.gemfile
    # JRuby head
    - rvm: jruby-head
      gemfile: gemfiles/mysql2/5-2.gemfile
    - rvm: jruby-head
      gemfile: gemfiles/postgresql/5-2.gemfile
    - rvm: jruby-head
      gemfile: gemfiles/sqlite3/5-2.gemfile
    #
    # The past
    #
    # EOL Active Record
    # Rails 3.2 was maintained longer and is ruby 2.2 compatible
    - rvm: 2.2.10
      gemfile: gemfiles/postgresql/3-2.gemfile
    - rvm: 2.2.10
      gemfile: gemfiles/sqlite3/3-2.gemfile
    # Rails <= 4.0 was only compatible with ruby 2.0
    # The test were running, but there are known incompatibilites
    - rvm: 2.0.0-p648
      gemfile: gemfiles/postgresql/3-0.gemfile
    - rvm: 2.0.0-p648
      gemfile: gemfiles/postgresql/3-1.gemfile
    - rvm: 2.0.0-p648
      gemfile: gemfiles/sqlite3/3-0.gemfile
    - rvm: 2.0.0-p648
      gemfile: gemfiles/sqlite3/3-1.gemfile
    - rvm: 2.0.0-p648
      gemfile: gemfiles/postgresql/4-0.gemfile
    - rvm: 2.0.0-p648
      gemfile: gemfiles/sqlite3/4-0.gemfile
    # Rails 4.1 was only compatible with ruby 2.1
    - rvm: 2.1.9
      gemfile: gemfiles/mysql2/4-1.gemfile
    - rvm: 2.1.9
      gemfile: gemfiles/postgresql/4-1.gemfile
    - rvm: 2.1.9
      gemfile: gemfiles/sqlite3/4-1.gemfile
    # Rails 5.0 was EOL with the release of 5.2
    - rvm: 2.4.6
      gemfile: gemfiles/mysql2/5-0.gemfile
    - rvm: 2.4.6
      gemfile: gemfiles/postgresql/5-0.gemfile
    - rvm: 2.4.6
      gemfile: gemfiles/sqlite3/5-0.gemfile
    #
    # The parallel dimension
    #
    # Rubinius
    - rvm: rbx-2
      gemfile: gemfiles/mysql2/5-1.gemfile
    - rvm: rbx-2
      gemfile: gemfiles/postgresql/5-1.gemfile
    - rvm: rbx-2
      gemfile: gemfiles/sqlite3/5-1.gemfile

sudo: false