File: ecma-re-validator.gemspec

package info (click to toggle)
ruby-ecma-re-validator 0.2.1-2
  • links: PTS, VCS
  • area: main
  • in suites: bullseye, sid
  • size: 180 kB
  • sloc: ruby: 301; makefile: 4; sh: 3
file content (26 lines) | stat: -rw-r--r-- 1,097 bytes parent folder | download | duplicates (2)
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
# frozen_string_literal: true

$LOAD_PATH.push File.expand_path('lib', __dir__)
require 'ecma-re-validator/version'

Gem::Specification.new do |gem|
  gem.name          = 'ecma-re-validator'
  gem.version       = EcmaReValidator::VERSION
  gem.authors       = ['Garen Torikian']
  gem.email         = ['gjtorikian@gmail.com']
  gem.description   = %(Validate a regular expression string against what ECMA-262 can actually do.)
  gem.summary       = %(Validate a regular expression string against what ECMA-262 can actually do.)
  gem.homepage      = 'https://github.com/gjtorikian/ecma-re-validator'
  gem.license       = 'MIT'
  all_files         = Dir.glob("**/*").select {|v| v !~ /^debian/}
  gem.files         = all_files.reject { |f| f =~ %r{^vendor/.*} }
  gem.test_files    = gem.files.grep(%r{^(spec)/})
  gem.require_paths = ['lib']

  gem.add_dependency 'regexp_parser', '~> 1.2'

  gem.add_development_dependency 'rspec', '~> 3.1'
  gem.add_development_dependency 'rake', '~> 13.0'
  gem.add_development_dependency 'awesome_print'
  gem.add_development_dependency 'pry', '~> 0.10'
end