File: changelog

package info (click to toggle)
ruby-feedparser 0.9.4-1
  • links: PTS, VCS
  • area: main
  • in suites: bullseye, buster, sid, stretch
  • size: 248 kB
  • ctags: 318
  • sloc: ruby: 3,009; sh: 24; makefile: 4
file content (196 lines) | stat: -rw-r--r-- 6,465 bytes parent folder | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
135
136
137
138
139
140
141
142
143
144
145
146
147
148
149
150
151
152
153
154
155
156
157
158
159
160
161
162
163
164
165
166
167
168
169
170
171
172
173
174
175
176
177
178
179
180
181
182
183
184
185
186
187
188
189
190
191
192
193
194
195
196
ruby-feedparser (0.9.4-1) unstable; urgency=medium

  [ Lucas Nussbaum ]
  * Update my email address.

  [ C├ędric Boutillier ]
  * Bump debhelper compatibility level to 9
  * Remove version in the gem2deb build-dependency
  * Use https:// in Vcs-* fields
  * Bump Standards-Version to 3.9.7 (no changes needed)
  * Run wrap-and-sort on packaging files

  [ Antonio Terceiro ]
  * New upstream release
  * Update packaging with a new dh-make-ruby run

 -- Antonio Terceiro <terceiro@debian.org>  Fri, 25 Mar 2016 11:11:10 -0300

ruby-feedparser (0.9.3-2) unstable; urgency=medium

  * Copy gemspec from .gem file to fix rubygems-integration support

 -- Antonio Terceiro <terceiro@debian.org>  Sun, 23 Mar 2014 17:05:02 -0300

ruby-feedparser (0.9.3-1) unstable; urgency=medium

  * New upstream release
    + Includes fix for crash when parsing URL's with non-ascii characters.
      Closes: #737767

 -- Antonio Terceiro <terceiro@debian.org>  Fri, 07 Feb 2014 09:34:23 -0300

ruby-feedparser (0.9.2-2) unstable; urgency=low

  * Upload to unstable. I have been using this version for almos 3 weeks
    without problems.
  * debian/control:
    + add myself to Uploaders:
    + add Breaks: on feed2imap (<< 1.2) to allow for a seamless upgrade path
      since this package has to be uploaded before the feed2imap 1.2
    + Build-Depends: add ruby-mocha

 -- Antonio Terceiro <terceiro@debian.org>  Sun, 15 Sep 2013 12:13:20 -0300

ruby-feedparser (0.9.2-1) experimental; urgency=low

  * Team upload
  * New upstream release fixing API regressions

 -- Antonio Terceiro <terceiro@debian.org>  Tue, 27 Aug 2013 22:47:44 -0300

ruby-feedparser (0.9-1) experimental; urgency=low

  * Team upload
  * New upstream release

 -- Antonio Terceiro <terceiro@debian.org>  Tue, 27 Aug 2013 22:22:16 -0300

ruby-feedparser (0.8.1-1) experimental; urgency=low

  * Team upload
  * New upstream release
    + splits test cases by input file, cleaner test output
    + more robust encoding handling
  * debian/ruby-tests.rb: run a little more unit tests during build

 -- Antonio Terceiro <terceiro@debian.org>  Tue, 27 Aug 2013 18:22:53 -0300

ruby-feedparser (0.8-1) experimental; urgency=low

  * Team upload
  * debian/watch: updated to pull upstream tarballs from
    http://people.debian.org/~terceiro/ruby-feedparser/
  * debian/rules: forcing UTF-8 locale during build
  * debian/ruby-tests.rb: skip tests for Ruby < 1.9 since 1.8 is not really
    supported anymore.
  * debian/control:
    - drop lib*-ruby* transitional packages
    - Bump standards version to 3.9.4. No changes needed
  * New upstream version adding Ruby 1.9 support

 -- Antonio Terceiro <terceiro@debian.org>  Sat, 24 Aug 2013 18:32:44 -0300

ruby-feedparser (0.7-2) unstable; urgency=low

  * Switch to gem2deb-based packaging. Rename source and binary packages.

 -- Lucas Nussbaum <lucas@lucas-nussbaum.net>  Sun, 17 Apr 2011 09:52:21 +0200

libfeedparser-ruby (0.7-1) unstable; urgency=low

  [ Lucas Nussbaum ]
  * New upstream release.

  [ Gunnar Wolf ]
  * Changed section to Ruby as per ftp-masters' request

  [ Lucas Nussbaum ]
  * Update to policy 3.8.2; no changes needed.
  * Add misc:Depends to Depends so lintian is happier.
  * Move ruby-pkg-tools to Build-Depends so lintian is happier. also
    move others Build-Depends-Indep to Build-Depends. We don't build any
    arch-specific package anyway, so splitting Build-Depends-Indep and
    Build-Depends in pointless.

 -- Lucas Nussbaum <lucas@lucas-nussbaum.net>  Tue, 28 Jul 2009 00:12:36 +0200

libfeedparser-ruby (0.6-1) unstable; urgency=low

  * New upstream release.
  * Bumped Standards-Version to 3.8.0. No changes needed.

 -- Lucas Nussbaum <lucas@lucas-nussbaum.net>  Wed, 23 Jul 2008 20:59:14 +0200

libfeedparser-ruby (0.5-3) unstable; urgency=low

  * Fix bashism in debian/rules. Caused different package content when
    built with dash. (Closes: #459171)

 -- Lucas Nussbaum <lucas@lucas-nussbaum.net>  Fri, 04 Jan 2008 16:39:31 +0100

libfeedparser-ruby (0.5-2) unstable; urgency=low

  * Added Vcs-Svn and Vcs-Browser
  * fixed Vcs-*: point to dir containing debian/, not dir containing
    trunk/
  * Upgraded to policy 3.7.3. No changes needed. 

 -- Lucas Nussbaum <lucas@lucas-nussbaum.net>  Mon, 24 Dec 2007 16:33:55 +0100

libfeedparser-ruby (0.5-1) unstable; urgency=low

  [ Lucas Nussbaum ]
  * New upstream release.

  [ Arnaud Cornet ]
  * Use new Homepage dpkg header.

 -- Lucas Nussbaum <lucas@lucas-nussbaum.net>  Fri, 26 Oct 2007 12:45:07 +0200

libfeedparser-ruby (0.4-1) unstable; urgency=low

  * New upstream release.
  * Removed the Uploaders rule.

 -- Lucas Nussbaum <lucas@lucas-nussbaum.net>  Tue, 15 May 2007 19:47:53 +0200

libfeedparser-ruby (0.2-1) unstable; urgency=low

  * New upstream release.
    - correct handling of <link> with to type attribute in ATOM feeds
      (closes: 369390).
  * Upgraded to policy 3.7.2 (no changes required).
  * Increased build-deps on debhelper and ruby-pkg-tools, since we were
    setting debian/compat to 5 anyway.
  * No longer calls dh_rdoc in debian/rules, since cdbs does it for us.
  * No longer tries to install rdoc/, since dh_rdoc generates the doc
    directly in the target directory.

 -- Lucas Nussbaum <lucas@lucas-nussbaum.net>  Tue, 13 Jun 2006 12:40:29 +0200

libfeedparser-ruby (0.1-4) unstable; urgency=low

  [ Lucas Nussbaum ]
  * Set the Maintainer field back to me. I will be mainly responsible
    for this package.

  [ Paul van Tilburg ]
  * Updated the team substvar to @RUBY_EXTRAS_TEAM@ in control, update
    the Build-Depend-Indep on ruby-pkg-tools.

 -- Paul van Tilburg <paulvt@debian.org>  Thu, 30 Mar 2006 14:27:21 +0200

libfeedparser-ruby (0.1-3) unstable; urgency=low

  [ Paul van Tilburg ]
  * Set the Maintainer field to the Debian/Ruby Extras team's name and
    address in debian/control.in since the package is team maintained.

  [ Thierry Reding ]
  * Set the libfeedparser-ruby-doc package's section to `doc' in order to make
    the Debian Installer happy.

 -- Thierry Reding <thierry@doppeltgemoppelt.de>  Thu, 12 Jan 2006 23:37:13 +0100

libfeedparser-ruby (0.1-2) unstable; urgency=low

  * Added the build dependancies for cdbs and ruby-pkg-tools.

 -- Lucas Nussbaum <lucas@lucas-nussbaum.net>  Wed, 11 Jan 2006 12:12:12 +0100

libfeedparser-ruby (0.1-1) unstable; urgency=low

  * First Debian package.

 -- Lucas Nussbaum <lucas@lucas-nussbaum.net>  Wed, 24 Nov 2005 10:39:00 +0200