File: control

package info (click to toggle)
ruby-gnome 3.4.1-1
  • links: PTS, VCS
  • area: main
  • in suites: bullseye, sid
  • size: 29,100 kB
  • sloc: ansic: 97,011; ruby: 70,696; xml: 350; sh: 105; cpp: 45; makefile: 29
file content (416 lines) | stat: -rw-r--r-- 14,715 bytes parent folder | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
135
136
137
138
139
140
141
142
143
144
145
146
147
148
149
150
151
152
153
154
155
156
157
158
159
160
161
162
163
164
165
166
167
168
169
170
171
172
173
174
175
176
177
178
179
180
181
182
183
184
185
186
187
188
189
190
191
192
193
194
195
196
197
198
199
200
201
202
203
204
205
206
207
208
209
210
211
212
213
214
215
216
217
218
219
220
221
222
223
224
225
226
227
228
229
230
231
232
233
234
235
236
237
238
239
240
241
242
243
244
245
246
247
248
249
250
251
252
253
254
255
256
257
258
259
260
261
262
263
264
265
266
267
268
269
270
271
272
273
274
275
276
277
278
279
280
281
282
283
284
285
286
287
288
289
290
291
292
293
294
295
296
297
298
299
300
301
302
303
304
305
306
307
308
309
310
311
312
313
314
315
316
317
318
319
320
321
322
323
324
325
326
327
328
329
330
331
332
333
334
335
336
337
338
339
340
341
342
343
344
345
346
347
348
349
350
351
352
353
354
355
356
357
358
359
360
361
362
363
364
365
366
367
368
369
370
371
372
373
374
375
376
377
378
379
380
381
382
383
384
385
386
387
388
389
390
391
392
393
394
395
396
397
398
399
400
401
402
403
404
405
406
407
408
409
410
411
412
413
414
415
416
Source: ruby-gnome
Section: ruby
Priority: optional
Maintainer: Debian Ruby Extras Maintainers <pkg-ruby-extras-maintainers@lists.alioth.debian.org>
Uploaders: Paul van Tilburg <paulvt@debian.org>,
           Michael Schutte <m.schutte.jr@gmail.com>,
           HIGUCHI Daisuke (VDR dai) <dai@debian.org>
Build-Depends: debhelper-compat (= 12),
               gem2deb (>= 0.4.1~),
               dctrl-tools,
               rake-compiler,
               ruby-mechanize,
               libgirepository1.0-dev,
               libgstreamer-plugins-base1.0-dev,
               libgstreamer1.0-dev,
               libgtksourceview-3.0-dev,
               libgtk2.0-dev,
               libjpeg-dev,
               libpng-dev,
               librsvg2-dev (>= 2.8.0),
               libxmu-dev,
               pkg-config,
               ruby-cairo,
               ruby-pkg-config (>= 1.3.5)
Standards-Version: 4.4.1
Homepage: http://ruby-gnome2.osdn.jp/
Vcs-Browser: https://salsa.debian.org/ruby-team/ruby-gnome
Vcs-Git: https://salsa.debian.org/ruby-team/ruby-gnome.git
XS-Ruby-Versions: all
Rules-Requires-Root: no

Package: ruby-glib2
Architecture: any
XB-Ruby-Versions: ${ruby:Versions}
X-DhRuby-Root: glib2
Depends: ruby | ruby-interpreter,
         ruby-pkg-config (>= 1.3.5),
         ${misc:Depends},
         ${shlibs:Depends}
Multi-Arch: same
Description: GLib 2 bindings for the Ruby language
 GLib is a useful general-purpose C library, notably used by GTK+ and GNOME.
 .
 This package contains libraries for using GLib 2 with the Ruby programming
 language. It is most likely useful in conjunction with Ruby bindings for
 other libraries such as GTK+.

Package: ruby-atk
Architecture: all
XB-Ruby-Versions: ${ruby:Versions}
X-DhRuby-Root: atk
Depends: gir1.2-atk-1.0,
         ruby | ruby-interpreter,
         ruby-gobject-introspection (>= ${source:Version}),
         ruby-glib2 (>= ${source:Version}),
         ${misc:Depends}
Multi-Arch: foreign
Description: ATK bindings for the Ruby language
 ATK is a toolkit providing accessibility interfaces for applications or other
 toolkits. By implementing these interfaces, those other toolkits or
 applications can be used with tools such as screen readers, magnifiers, and
 other alternative input devices.
 .
 This package contains libraries for using ATK with the Ruby programming
 language.

Package: ruby-cairo-gobject
Architecture: any
XB-Ruby-Versions: ${ruby:Versions}
X-DhRuby-Root: cairo-gobject
Depends: ruby | ruby-interpreter,
         ruby-cairo,
         ruby-glib2 (= ${binary:Version}),
         ${misc:Depends},
         ${shlibs:Depends}
Multi-Arch: same
Description: CairoGObject bindings for the Ruby language
 Cairo is a multi-platform library providing anti-aliased vector-based
 rendering for multiple target backends; CairoGObject provides
 wrapper GObject types for all Cairo types.
 .
 This package contains libraries for CairoGObject with the Ruby language.

Package: ruby-clutter
Architecture: all
XB-Ruby-Versions: ${ruby:Versions}
X-DhRuby-Root: clutter
Depends: gir1.2-clutter-1.0,
         ruby | ruby-interpreter,
         ruby-atk (>= ${source:Version}),
         ruby-cairo-gobject (>= ${source:Version}),
         ruby-gdk-pixbuf2 (>= ${source:Version}),
         ruby-gobject-introspection (>= ${source:Version}),
         ruby-pango (>= ${source:Version}),
         ${misc:Depends}
Multi-Arch: foreign
Description: Clutter bindings for the Ruby language
 Clutter is a GObject based library for creating fast, visually rich,
 graphical user interfaces.  Clutter works by manipulating a scene-graph of
 2D surfaces, or 'actors', inside a 3D space.
 .
 This package contains libraries for using Clutter with the Ruby language.

Package: ruby-clutter-gdk
Architecture: all
XB-Ruby-Versions: ${ruby:Versions}
X-DhRuby-Root: clutter-gdk
Depends: gir1.2-clutter-1.0,
         ruby | ruby-interpreter,
         ruby-clutter (>= ${source:Version}),
         ruby-gdk3 (>= ${source:Version}),
         ${misc:Depends}
Multi-Arch: foreign
Description: Clutter-Gdk bindings for the Ruby language
 Clutter-Gdk is a library for GDK specific API of Clutter. This library
 provides some specific API, allowing integration with the GDK API for
 manipulating the stage window and handling events outside of Clutter.
 .
 This package contains libraries for using Clutter-Gdk with the Ruby language.

Package: ruby-clutter-gtk
Architecture: all
XB-Ruby-Versions: ${ruby:Versions}
X-DhRuby-Root: clutter-gtk
Depends: gir1.2-gtkclutter-1.0,
         ruby | ruby-interpreter,
         ruby-clutter (>= ${source:Version}),
         ruby-clutter-gdk (>= ${source:Version}),
         ruby-gtk3 (>= ${source:Version}),
         ${misc:Depends}
Multi-Arch: foreign
Description: Clutter-Gtk bindings for the Ruby language
 Clutter-Gtk is an integration library for the Clutter toolkit providing
 access and integration for the GTK+ library.  Clutter-Gtk allows embedding
 a Clutter scene graph into a GTK+ application; retrieving themeing
 information; integrate GTK+ data structures and object classes with
 Clutter actors.
 .
 This package contains libraries for using Clutter-Gtk with the Ruby language.

Package: ruby-gdk-pixbuf2
Architecture: all
XB-Ruby-Versions: ${ruby:Versions}
X-DhRuby-Root: gdk_pixbuf2
Depends: ruby | ruby-interpreter,
         gir1.2-gdkpixbuf-2.0,
         ruby-gobject-introspection (>= ${source:Version}),
         ruby-gio2 (>= ${source:Version}),
         ${misc:Depends}
Multi-Arch: foreign
Description: Gdk-Pixbuf 2 bindings for the Ruby language
 Gdk-Pixbuf is a library for loading and rendering images.
 .
 This package contains libraries for using Gdk-Pixbuf with the Ruby programming
 language.

Package: ruby-gdk3
Architecture: all
XB-Ruby-Versions: ${ruby:Versions}
X-DhRuby-Root: gdk3
Depends: ruby | ruby-interpreter,
         gir1.2-gtk-3.0,
         ruby-atk (>= ${source:Version}),
         ruby-cairo-gobject (>= ${source:Version}),
         ruby-gdk-pixbuf2 (>= ${source:Version}),
         ruby-gobject-introspection (>= ${source:Version}),
         ruby-pango (>= ${source:Version}),
         ${misc:Depends}
Multi-Arch: foreign
Description: GDK 3 bindings for the Ruby language
 GDK is a computer graphics library that acts as a wrapper around the
 low-level drawing and windowing functions provided by the underlying
 graphics system.  It is mainly use by GTK+ 3.
 .
 This package contains libraries for using GDK 3 with the Ruby programming
 language.

Package: ruby-gio2
Architecture: any
XB-Ruby-Versions: ${ruby:Versions}
X-DhRuby-Root: gio2
Depends: ruby | ruby-interpreter,
         gir1.2-glib-2.0,
         ruby-glib2 (= ${binary:Version}),
         ruby-gobject-introspection (= ${binary:Version}),
         ${misc:Depends},
         ${shlibs:Depends}
Multi-Arch: same
Description: GIO bindings for the Ruby language
 GIO is striving to provide a modern, easy-to-use VFS API that sits at the
 right level in the library stack, as well as other generally useful APIs for
 desktop applications such as networking and D-Bus support.
 .
 This package provides GIO bindings to be used in Ruby programs.

Package: ruby-gnome
Architecture: all
Depends: ruby-atk,
         ruby-cairo-gobject,
         ruby-gdk-pixbuf2,
         ruby-gdk3,
         ruby-gio2,
         ruby-gstreamer,
         ruby-gtk3,
         ruby-gtksourceview4,
         ruby-pango,
         ruby-poppler,
         ruby-rsvg2,
         ${misc:Depends}
Breaks: ruby-gnome2 (<< 3.3.8)
Replaces: ruby-gnome2 (<< 3.3.8)
Multi-Arch: foreign
Description: GNOME-related bindings for the Ruby language
 These bindings allow use of the GNOME developer platform using the Ruby
 programming language.
 .
 This is an empty package that depends on the various packages that provide
 the individual bindings.

Package: ruby-gnome2
Depends: ${misc:Depends}, ruby-gnome
Architecture: all
Section: oldlibs
Description: transitional package for ruby-gnome
 This is a transitional package for ruby-gnome. It can safely be removed.

Package: ruby-gnome-dev
Architecture: any
Section: libdevel
Depends: ruby-all-dev,
         ruby-gnome,
         ruby-pkg-config,
         ${misc:Depends}
Breaks: ruby-gnome2-dev (<< 3.3.8)
Replaces: ruby-gnome2-dev (<< 3.3.8)
Multi-Arch: same
Description: GNOME-related bindings for the Ruby language (development files)
 These bindings allow use of the GNOME developer platform using the Ruby
 programming language.
 .
 This package contains development files required to build ruby-gnome
 extensions.

Package: ruby-gnome2-dev
Depends: ${misc:Depends}, ruby-gnome-dev
Architecture: all
Section: oldlibs
Description: transitional package for ruby-gnome-dev
 This is a transitional package for ruby-gnome-dev. It can safely be removed.

Package: ruby-gobject-introspection
Architecture: any
XB-Ruby-Versions: ${ruby:Versions}
X-DhRuby-Root: gobject-introspection
Depends: ruby | ruby-interpreter,
         ruby-glib2 (= ${binary:Version}),
         ${misc:Depends},
         ${shlibs:Depends}
Multi-Arch: same
Description: GObject Introspection bindings for the Ruby language
 GObject Introspection is a project for providing machine readable
 introspection data of the API of C libraries.  This introspection data can
 be used in several different use cases, for example automatic code
 generation for bindings, API verification and documentation generation.
 .
 This package contains library for using GObject Introspection with the Ruby
 programming language.

Package: ruby-gstreamer
Architecture: any
XB-Ruby-Versions: ${ruby:Versions}
X-DhRuby-Root: gstreamer
Depends: ruby | ruby-interpreter,
         gir1.2-gstreamer-1.0,
         ruby-atk (>= ${source:Version}),
         ruby-gdk-pixbuf2 (>= ${source:Version}),
         ruby-gobject-introspection (= ${binary:Version}),
         ruby-pango (= ${binary:Version}),
         ${misc:Depends},
         ${shlibs:Depends}
Multi-Arch: same
Description: GStreamer bindings for the Ruby language
 GStreamer is a media processing framework with support for a wide variety of
 data sources, sinks, and formats through the use of dynamically loaded
 plugins.
 .
 This package contains libraries for using GStreamer with the Ruby programming
 language.

Package: ruby-gtk2
Architecture: any
XB-Ruby-Versions: ${ruby:Versions}
X-DhRuby-Root: gtk2
Depends: ruby | ruby-interpreter,
         ruby-atk (>= ${source:Version}),
         ruby-gdk-pixbuf2 (>= ${source:Version}),
         ruby-pango (= ${binary:Version}),
         ${misc:Depends},
         ${shlibs:Depends}
Multi-Arch: same
Description: GTK+ 2 bindings for the Ruby language
 GTK+ is a multi-platform toolkit for creating graphical user interfaces.
 Offering a complete set of widgets, GTK+ is suitable for projects ranging
 from small one-off tools to complete application suites.
 .
 This package contains libraries for using GTK+ 2 with the Ruby programming
 language.

Package: ruby-gtk3
Architecture: any
XB-Ruby-Versions: ${ruby:Versions}
X-DhRuby-Root: gtk3
Depends: ruby | ruby-interpreter,
         ruby-atk (>= ${source:Version}),
         ruby-gdk3 (>= ${source:Version}),
         ${misc:Depends},
         ${shlibs:Depends}
Multi-Arch: same
Description: GTK+ 3 bindings for the Ruby language
 GTK+ is a multi-platform toolkit for creating graphical user interfaces.
 Offering a complete set of widgets, GTK+ is suitable for projects ranging
 from small one-off tools to complete application suites.
 .
 This package contains libraries for using GTK+ 3 with the Ruby programming
 language.

Package: ruby-gtksourceview4
Architecture: all
XB-Ruby-Versions: ${ruby:Versions}
X-DhRuby-Root: gtksourceview4
Depends: ruby | ruby-interpreter,
         gir1.2-gtksource-4,
         ruby-gtk3 (>= ${source:Version}),
         ${misc:Depends}
Multi-Arch: foreign
Description: GtkSourceView4 bindings for the Ruby language
 GTKSourceView4 is a text widget that extends the standard GTK+ text widget.
 .
 This package contains libraries for using the GtkSourceView4 text widget
 with syntax highlighting and other features typical of a source code
 editor in the Ruby programming language.

Package: ruby-pango
Architecture: any
XB-Ruby-Versions: ${ruby:Versions}
X-DhRuby-Root: pango
Depends: ruby | ruby-interpreter,
         gir1.2-pango-1.0,
         ruby-gobject-introspection (= ${binary:Version}),
         ruby-cairo-gobject (= ${binary:Version}),
         ${misc:Depends},
         ${shlibs:Depends}
Multi-Arch: same
Description: Pango bindings for the Ruby language
 Pango is a library for layout and rendering of text, with an emphasis on
 internationalization.
 .
 This package contains libraries for using Pango with the Ruby programming
 language.

Package: ruby-poppler
Architecture: all
XB-Ruby-Versions: ${ruby:Versions}
X-DhRuby-Root: poppler
Depends: ruby | ruby-interpreter,
         gir1.2-poppler-0.18,
         ruby-gobject-introspection (>= ${source:Version}),
         ruby-gio2 (>= ${source:Version}),
         ruby-cairo-gobject (>= ${source:Version}),
         ${misc:Depends}
Multi-Arch: foreign
Description: Ruby bindings for the libpoppler-glib library
 Poppler is a PDF rendering library based on xpdf PDF viewer.
 libpoppler-glib is Glib binding for Poppler.
 .
 This package contains ruby bindings for libpoppler-glib.

Package: ruby-rsvg2
Architecture: all
XB-Ruby-Versions: ${ruby:Versions}
X-DhRuby-Root: rsvg2
Depends: gir1.2-rsvg-2.0,
         ruby | ruby-interpreter,
         ruby-glib2 (>= ${source:Version}),
         ruby-gio2 (>= ${source:Version}),
         ruby-gdk-pixbuf2 (>= ${source:Version}),
         ruby-cairo-gobject (>= ${source:Version}),
         ruby-pango (>= ${source:Version}),
         ${misc:Depends}
Multi-Arch: foreign
Description: RSVG renderer bindings for the Ruby language
 The rsvg library is an efficient renderer for Scalable Vector Graphics (SVG)
 pictures.
 .
 This package contains libraries for using RSVG with the Ruby programming
 language.

Package: ruby-webkit2-gtk
Architecture: all
XB-Ruby-Versions: ${ruby:Versions}
X-DhRuby-Root: webkit2-gtk
Depends: gir1.2-webkit2-4.0,
         ruby | ruby-interpreter,
         ruby-gobject-introspection (>= ${source:Version}),
         ruby-gtk3 (>= ${source:Version}),
         ${misc:Depends}
Multi-Arch: foreign
Description: WebKitGTK+ bindings for the Ruby language
 WebKitGTK+ is the GNOME platform port of the WebKit rendering engine.
 Offering WebKit’s full functionality through a set of GObject-based APIs,
 it is suitable for projects requiring any kind of web integration, from
 hybrid HTML/CSS applications to full-fledged web browsers, like Epiphany
 and Midori.
 .
 This package contains libraries for using WebKitGTK+ with GTK+ 3 and the Ruby
 language.