File: changelog

package info (click to toggle)
ruby-gpgme 2.0.18-1
  • links: PTS, VCS
  • area: main
  • in suites: bullseye, buster, sid
  • size: 3,156 kB
  • sloc: ruby: 3,094; ansic: 2,556; makefile: 5
file content (254 lines) | stat: -rw-r--r-- 7,990 bytes parent folder | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
135
136
137
138
139
140
141
142
143
144
145
146
147
148
149
150
151
152
153
154
155
156
157
158
159
160
161
162
163
164
165
166
167
168
169
170
171
172
173
174
175
176
177
178
179
180
181
182
183
184
185
186
187
188
189
190
191
192
193
194
195
196
197
198
199
200
201
202
203
204
205
206
207
208
209
210
211
212
213
214
215
216
217
218
219
220
221
222
223
224
225
226
227
228
229
230
231
232
233
234
235
236
237
238
239
240
241
242
243
244
245
246
247
248
249
250
251
252
253
254
ruby-gpgme (2.0.18-1) unstable; urgency=medium

  * New upstream release.
  * debian/compat:
    - Drop obsolete compat file.
  * debian/control:
    - Use Alioth mailing list in Maintainer field.
    - Add build dependency on debhelper-compat.
    - Bump Standards-Version to 4.2.1.
    - Declare that the build doesn't need root privileges.
    - Wrap and sort.
  * debian/copyright:
    - Wrap and sort.
  * debian/patches:
    - Refresh for new release.
  * debian/rules:
    - Make the build verbose.
  * debian/watch:
    - Use version 4 and pull releases from GitHub. The current gem file
      contains a gemspec with non-ASCII characters, which leads to fatal quilt
      errors.
  * debian/.gitlab-ci.yml:
    - Introduce Salsa CI config.

 -- Georg Faerber <georg@riseup.net>  Sun, 16 Dec 2018 17:38:09 +0000

ruby-gpgme (2.0.16-1) unstable; urgency=medium

  * New upstream release.
  * debian/changelog: Remove trailing whitespace.
  * debian/control:
    - Bump Standards-Version to 4.1.3, no changes needed.
    - Use salsa.debian.org in Vcs-Browser and Vcs-Git fields, as
      anonscm.debian.org is deprecated and accordingly, all repositories were
      moved.
    - Use debian-ruby@lists.debian.org for Maintainer field.
  * debian/copyright: Bump years to include 2018.
  * debian/patches: Refresh for release 2.0.16-1.

 -- Georg Faerber <georg@riseup.net>  Wed, 07 Feb 2018 22:37:24 +0100

ruby-gpgme (2.0.14-1) unstable; urgency=medium

  * New upstream release.
  * debian/control: Depend on libgpgme-dev, instead of the obsolete
    libgpgme11-dev.
  * debian/copyright:
    - Bump years and add missing Debian packaging authors.
    - Use https in links.

 -- Georg Faerber <georg@riseup.net>  Tue, 07 Nov 2017 15:38:02 +0100

ruby-gpgme (2.0.13-1) unstable; urgency=medium

  * New upstream release.
  * debian/compat: Bump debhelper compat to 10.
  * debian/control:
    - Bump Standards-Version to 4.1.1, no changes needed.
    - Bump required debhelper version.
    - Add myself as uploader.
    - Use https in homepage link.
  * debian/patches: Refresh for release 2.0.13-1.
  * debian/watch: Use https in gemwatch link.

 -- Georg Faerber <georg@riseup.net>  Mon, 23 Oct 2017 13:21:00 +0200

ruby-gpgme (2.0.12-1) unstable; urgency=medium

  * Team upload.

  [ Cédric Boutillier ]
  * Remove version in the gem2deb build-dependency
  * Use https:// in Vcs-* fields
  * Bump Standards-Version to 3.9.7 (no changes needed)
  * Run wrap-and-sort on packaging files

  [ Christian Hofstaedtler ]
  * New upstream version.
  * Update packaging using dh-make-ruby -w

 -- Christian Hofstaedtler <zeha@debian.org>  Sat, 05 Mar 2016 03:25:56 +0100

ruby-gpgme (2.0.9-1) unstable; urgency=medium

  * Team upload.
  * Imported Upstream version 2.0.9
  * Bump debhelper compatibility level to 9
  * Declare compliance with Debian policy 3.9.6

 -- Lucas Kanashiro <kanashiro.duarte@gmail.com>  Tue, 18 Aug 2015 20:02:10 -0300

ruby-gpgme (2.0.5-1) unstable; urgency=medium

  * Team upload.
  * New upstream release.
  * Increased Standards-Version to 3.9.5 (no changes).
  * Removed obsolete patch for dynamic build (with gpgme-config) and use
    --use-system-libraries option instead.

 -- Marc Dequènes (Duck) <Duck@DuckCorp.org>  Tue, 29 Apr 2014 22:54:11 +0200

ruby-gpgme (2.0.2-1) unstable; urgency=low

  * Team upload.

  [ Gunnar Wolf ]
  * Removed the build of transitional packages and obsolete
    relations required for Wheezy.

  [ Marc Dequènes (Duck) ]
  * New upstream release.
  * Patched buildsys to link with gpgme dynamically (and not with
    embedded libraries).
  * Increased Standards-Version to 3.9.4 (no changes).
  * Added dpkg-source local option to unapply patches.

 -- Marc Dequènes (Duck) <Duck@DuckCorp.org>  Mon, 12 Aug 2013 20:01:08 +0200

ruby-gpgme (2.0.0-2) unstable; urgency=low

  * Added myself as uploader.
  * Build depend on gem2deb >= 0.3.0.
  * Bump standards version to 3.9.3 (no changes needed).
  * Use copyright format 1.0 uri.
  * Changed short description.
    - Remove lintian warning.

  [ Vincent Fourmond ]
  * Moved transitional packages to Priority: extra

 -- Per Andersson <avtobiff@gmail.com>  Mon, 25 Jun 2012 23:37:48 +0200

ruby-gpgme (2.0.0-1) unstable; urgency=low

  * Repackaged using the Gem2deb infrastructure

 -- Gunnar Wolf <gwolf@debian.org>  Fri, 07 Oct 2011 12:11:01 -0500

libgpgme-ruby (1.0.8-3) unstable; urgency=low

  * Adopted package (Closes: #572175)
  * Dropped depensimple-patchsys from build process (no patches to
    apply)
  * Standards-version 3.8.1→3.8.4 (no changes needed)

 -- Gunnar Wolf <gwolf@debian.org>  Thu, 04 Mar 2010 07:56:54 -0600

libgpgme-ruby (1.0.8-2) unstable; urgency=low

  * Switch from Ruby 1.9 to 1.9.1. Closes: #565845.
  * Update debian/copyright. Closes: #538228.

 -- Lucas Nussbaum <lucas@lucas-nussbaum.net>  Sat, 13 Feb 2010 10:43:25 +0100

libgpgme-ruby (1.0.8-1) unstable; urgency=medium

  * New upstream release (Closes: #563380)

 -- Micah Anderson <micah@debian.org>  Fri, 05 Feb 2010 13:54:48 -0500

libgpgme-ruby (1.0.6-1) unstable; urgency=low

  * New upstream release.

 -- Rudi Cilibrasi <cilibrar@debian.org>  Tue, 09 Jun 2009 07:05:56 -0700

libgpgme-ruby (1.0.5-1) unstable; urgency=low

  * [Gunnar Wolf]
    - Changed section to Ruby as per ftp-masters' request.
  * [Rudi Cilibrasi]
    - New upstream release.

 -- Rudi Cilibrasi <cilibrar@debian.org>  Wed, 03 Jun 2009 18:30:02 -0700

libgpgme-ruby (1.0.4-1) unstable; urgency=low

  * New upstream release.

 -- Rudi Cilibrasi <cilibrar@debian.org>  Tue, 10 Feb 2009 04:35:22 -0800

libgpgme-ruby (1.0.1-2) unstable; urgency=low

  * Build-depend on ruby-pkg-tools >= 0.14, than fixes the ruby1.9 libs
    install problem (see #484611).

 -- Lucas Nussbaum <lucas@lucas-nussbaum.net>  Mon, 16 Jun 2008 15:06:45 +0200

libgpgme-ruby (1.0.1-1) unstable; urgency=low

  * New upstream release.  Removed patch for memleak fixed by upstream.

 -- Rudi Cilibrasi <cilibrar@debian.org>  Thu, 06 Mar 2008 10:44:42 -0800

libgpgme-ruby (1.0.0-3) unstable; urgency=low

  [ Rudi Cilibrasi ]
  * Bumped Standards-Version to 3.7.3.

  * Thanks to Paul van Tilburg for help in packaging libgpgme-ruby.

  [ Lucas Nussbaum ]
  * Use new Homepage dpkg header.

 -- Rudi Cilibrasi <cilibrar@debian.org>  Fri, 28 Dec 2007 23:18:40 -0800

libgpgme-ruby (1.0.0-2) unstable; urgency=low

  * Thanks to Andreas Barth for fixing broken compilation problem.

 -- Rudi Cilibrasi <cilibrar@cilibrar.com>  Tue, 23 Oct 2007 14:55:35 -0700

libgpgme-ruby (1.0.0-1.1) unstable; urgency=medium

  * Non-maintainer upload.
  * Fix FTBFS, thanks Michael Ablassmeier. Closes: #427450

 -- Andreas Barth <aba@not.so.argh.org>  Mon,  2 Jul 2007 20:27:44 +0000

libgpgme-ruby (1.0.0-1) unstable; urgency=low

  [ Rudi Cilibrasi ]
  * I am taking stewardship of the package for now as maintainer.
  * New upstream version.
  * Changed Build-Deps to specify libgpgme11-dev.
  * Updated Standards to 3.7.2.

  [ Paul van Tilburg ]
  * Updated homepage URL in debian/control and debian/watch,
    since the project moved to RubyForge.
  * Added myself to the Uploaders, currently acting as sponsor.
  * Adapted debian/rules, and removed debian/control.in to drop
    the Uploaders rule.

 -- Paul van Tilburg <paulvt@debian.org>  Wed, 18 Apr 2007 22:30:24 +0200

libgpgme-ruby (0.2-2) unstable; urgency=low

  [ Thierry Reding ]
  * Set myself as maintainer, taking 'ownership' of the package.
  * Updated debian/control.in to use @RUBY_EXTRAS_TEAM@ instead of the
    deprecated @RUBY_TEAM@ (build-depends on ruby-pkg-tools >= 0.8).

  [ Paul van Tilburg ]
  * Added debian/watch file.

 -- Paul van Tilburg <paulvt@debian.org>  Thu, 30 Mar 2006 13:49:20 +0200

libgpgme-ruby (0.2-1) unstable; urgency=low

  * Initial release. (Closes: #351270)
  * Uses the new extconf.rb CDBS class (depends on ruby-pkg-tools >= 0.7).

 -- Thierry Reding <thierry@doppeltgemoppelt.de>  Fri, 24 Feb 2006 19:04:34 +0100