File: jsonpath.gemspec

package info (click to toggle)
ruby-jsonpath 1.0.5-2
  • links: PTS, VCS
  • area: main
  • in suites: bullseye, sid
  • size: 220 kB
  • sloc: ruby: 1,327; makefile: 4
file content (35 lines) | stat: -rw-r--r-- 1,357 bytes parent folder | download | duplicates (2)
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
# frozen_string_literal: true

require File.join(File.dirname(__FILE__), 'lib', 'jsonpath', 'version')

Gem::Specification.new do |s|
  s.name = 'jsonpath'
  s.version = JsonPath::VERSION
  if s.respond_to? :required_rubygems_version=
    s.required_rubygems_version =
      Gem::Requirement.new('>= 0')
  end
  s.authors = ['Joshua Hull', 'Gergely Brautigam']
  s.summary = 'Ruby implementation of http://goessner.net/articles/JsonPath/'
  s.description = 'Ruby implementation of http://goessner.net/articles/JsonPath/.'
  s.email = ['joshbuddy@gmail.com', 'skarlso777@gmail.com']
  s.extra_rdoc_files = ['README.md']
  s.files = `git ls-files`.split("\n")
  s.homepage = 'https://github.com/joshbuddy/jsonpath'
  s.rdoc_options = ['--charset=UTF-8']
  s.require_paths = ['lib']
  s.rubygems_version = '1.3.7'
  s.test_files = `git ls-files`.split("\n").select { |f| f =~ /^spec/ }
  s.rubyforge_project = 'jsonpath'
  s.executables = `git ls-files -- bin/*`.split("\n").map { |f| File.basename(f) }
  s.licenses    = ['MIT']

  # dependencies
  s.add_runtime_dependency 'multi_json'
  s.add_runtime_dependency 'to_regexp', '~> 0.2.1'
  s.add_development_dependency 'bundler'
  s.add_development_dependency 'code_stats'
  s.add_development_dependency 'minitest', '~> 2.2.0'
  s.add_development_dependency 'phocus'
  s.add_development_dependency 'rake'
end