File: metadata.yml

package info (click to toggle)
ruby-magic 0.2.9-1
  • links: PTS, VCS
  • area: main
  • in suites: bullseye, buster, sid, stretch
  • size: 160 kB
  • ctags: 33
  • sloc: ruby: 187; makefile: 3
file content (149 lines) | stat: -rw-r--r-- 4,672 bytes parent folder | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
135
136
137
138
139
140
141
142
143
144
145
146
147
148
149
--- !ruby/object:Gem::Specification
name: magic
version: !ruby/object:Gem::Version
  version: 0.2.9
platform: ruby
authors:
- Kuba Ku┼║ma
autorequire: 
bindir: bin
cert_chain: []
date: 2015-04-16 00:00:00.000000000 Z
dependencies:
- !ruby/object:Gem::Dependency
  name: ffi
  requirement: !ruby/object:Gem::Requirement
    requirements:
    - - ">="
      - !ruby/object:Gem::Version
        version: 0.6.3
  type: :runtime
  prerelease: false
  version_requirements: !ruby/object:Gem::Requirement
    requirements:
    - - ">="
      - !ruby/object:Gem::Version
        version: 0.6.3
- !ruby/object:Gem::Dependency
  name: bundler
  requirement: !ruby/object:Gem::Requirement
    requirements:
    - - "~>"
      - !ruby/object:Gem::Version
        version: '1.5'
  type: :development
  prerelease: false
  version_requirements: !ruby/object:Gem::Requirement
    requirements:
    - - "~>"
      - !ruby/object:Gem::Version
        version: '1.5'
- !ruby/object:Gem::Dependency
  name: rake
  requirement: !ruby/object:Gem::Requirement
    requirements:
    - - ">="
      - !ruby/object:Gem::Version
        version: '0'
  type: :development
  prerelease: false
  version_requirements: !ruby/object:Gem::Requirement
    requirements:
    - - ">="
      - !ruby/object:Gem::Version
        version: '0'
- !ruby/object:Gem::Dependency
  name: test-unit
  requirement: !ruby/object:Gem::Requirement
    requirements:
    - - ">="
      - !ruby/object:Gem::Version
        version: '2.0'
  type: :development
  prerelease: false
  version_requirements: !ruby/object:Gem::Requirement
    requirements:
    - - ">="
      - !ruby/object:Gem::Version
        version: '2.0'
description: Ruby FFI bindings to libmagic
email:
- kuba@jah.pl
executables: []
extensions: []
extra_rdoc_files: []
files:
- ".gitignore"
- Gemfile
- LICENSE.txt
- README.rdoc
- Rakefile
- lib/magic.rb
- lib/magic/api.rb
- lib/magic/constants.rb
- lib/magic/database.rb
- lib/magic/errors.rb
- lib/magic/version.rb
- magic.gemspec
- test/fixtures/filelogo.jpg
- test/fixtures/magic.txt
- test/fixtures/magic_empty
- test/fixtures/magic_jpeg
- test/helper.rb
- test/test_magic.rb
homepage: https://github.com/qoobaa/magic
licenses:
- MIT
metadata: {}
post_install_message: |
  +-NOTE FOR LINUX USERS----------------------------------------------+
  |                                                                   |
  | Install libmagic using your package manager, e.g.                 |
  |                                                                   |
  |   sudo apt-get install file                                       |
  |                                                                   |
  +-NOTE FOR WINDOWS USERS -------------------------------------------+
  |                                                                   |
  | Install File for Windows from                                     |
  |                                                                   |
  |   http://gnuwin32.sourceforge.net/packages/file.htm               |
  |                                                                   |
  | You'll also need to set your PATH environment variable to the     |
  | directory of the magic1.dll file                                  |
  |                                                                   |
  |   set PATH=C:\Program Files\GnuWin32\bin;%PATH%                   |
  |                                                                   |
  +-NOTE FOR MAC OS USERS --------------------------------------------+
  |                                                                   |
  | If you don't have libmagic.1.dylib file in your system, you need  |
  | to install it using port command                                  |
  |                                                                   |
  |   sudo port install file                                          |
  |                                                                   |
  +-------------------------------------------------------------------+
rdoc_options: []
require_paths:
- lib
required_ruby_version: !ruby/object:Gem::Requirement
  requirements:
  - - ">="
    - !ruby/object:Gem::Version
      version: '0'
required_rubygems_version: !ruby/object:Gem::Requirement
  requirements:
  - - ">="
    - !ruby/object:Gem::Version
      version: '0'
requirements: []
rubyforge_project: 
rubygems_version: 2.4.5
signing_key: 
specification_version: 4
summary: Determine file type and encoding using "magic" numbers
test_files:
- test/fixtures/filelogo.jpg
- test/fixtures/magic.txt
- test/fixtures/magic_empty
- test/fixtures/magic_jpeg
- test/helper.rb
- test/test_magic.rb