File: mail-gpg.gemspec

package info (click to toggle)
ruby-mail-gpg 0.4.0-1~bpo9+1
  • links: PTS, VCS
  • area: main
  • in suites: stretch-backports
  • size: 320 kB
  • sloc: ruby: 2,133; makefile: 5
file content (29 lines) | stat: -rw-r--r-- 1,334 bytes parent folder | download | duplicates (3)
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
# coding: utf-8
lib = File.expand_path('../lib', __FILE__)
$LOAD_PATH.unshift(lib) unless $LOAD_PATH.include?(lib)
require 'mail/gpg/version'

Gem::Specification.new do |spec|
  spec.name          = "mail-gpg"
  spec.version       = Mail::Gpg::VERSION
  spec.authors       = ["Jens Kraemer"]
  spec.email         = ["jk@jkraemer.net"]
  spec.description   = "GPG/MIME encryption plugin for the Ruby Mail Library\nThis tiny gem adds GPG capabilities to Mail::Message and ActionMailer::Base. Because privacy matters."
  spec.summary       = %q{GPG/MIME encryption plugin for the Ruby Mail Library}
  spec.homepage      = "https://github.com/jkraemer/mail-gpg"
  spec.license       = "MIT"

  spec.files         = `git ls-files`.split($/)
  spec.executables   = spec.files.grep(%r{^bin/}) { |f| File.basename(f) }
  spec.test_files    = spec.files.grep(%r{^(test|spec|features)/})
  spec.require_paths = ["lib"]

  spec.add_dependency "mail", "~> 2.5", ">= 2.5.3"
  spec.add_dependency "gpgme", "~> 2.0", ">= 2.0.2"
  spec.add_development_dependency "bundler", "~> 1.3"
  spec.add_development_dependency "test-unit", "~> 3.0"
  spec.add_development_dependency "rake"
  spec.add_development_dependency "actionmailer", ">= 3.2.0"
  spec.add_development_dependency "byebug"
  spec.add_development_dependency "shoulda-context", '~> 1.1'
end