File: .rubocop.yml

package info (click to toggle)
ruby-mocha 1.7.0-1
  • links: PTS, VCS
  • area: main
  • in suites: bullseye, buster, sid
  • size: 1,440 kB
  • sloc: ruby: 11,613; makefile: 13
file content (58 lines) | stat: -rw-r--r-- 1,722 bytes parent folder | download | duplicates (2)
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
inherit_from: .rubocop_todo.yml

AllCops:
  TargetRubyVersion: 2.2 # closest to required_ruby_version of '>= 1.8.6'

# Even the reference in the documentation suggests that you should prefer
# `alias_method` vs `alias`, so I don't understand why that isn't the default.
Style/Alias:
  EnforcedStyle: prefer_alias_method

# Enumerable#each_with_object only available since Ruby v1.9
Style/EachWithObject:
  Enabled: false

# Kernel#__dir__ has only been available since Ruby v2.0
Style/ExpandPathArguments:
  Enabled: false

# Kernel#format has only supported named references since Ruby v1.9
Style/FormatStringToken:
  EnforcedStyle: unannotated

# ruby19 style has only been supported since Ruby v1.9
Style/HashSyntax:
  EnforcedStyle: hash_rockets

# I'm not keen on this cop, because it's easy to miss the conditional
# I think the results are particularly unhelpful when Metrics/LineLength is big
Style/IfUnlessModifier:
  Enabled: false

# Lambda literal syntax has only been supported since Ruby v2.0
Style/Lambda:
  EnforcedStyle: lambda

# Symbol array literal syntax has only been supported since Ruby v2.0
Style/SymbolArray:
  Enabled: false

# I'm not keen on this cop, because it's easy to miss the while/until
Style/WhileUntilModifier:
  Enabled: false

# This recently introduced cop seems to have stirred up some controversy
Style/AccessModifierDeclarations:
  Enabled: false

# Enabling this cop results in an "Infinite loop detected" exception
Layout/AccessModifierIndentation:
  Enabled: false

# Allow long comment lines, e.g. YARD documentation
Metrics/LineLength:
  IgnoredPatterns: ['\A\s*#']

# It's not possible to set TargetRubyVersion to Ruby < v2.2
Gemspec/RequiredRubyVersion:
  Enabled: false