File: mocha.gemspec

package info (click to toggle)
ruby-mocha 1.7.0-1
  • links: PTS, VCS
  • area: main
  • in suites: bullseye, buster, sid
  • size: 1,440 kB
  • sloc: ruby: 11,613; makefile: 13
file content (52 lines) | stat: -rw-r--r-- 1,551 bytes parent folder | download | duplicates (2)
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
lib = File.expand_path('../lib/', __FILE__)
$LOAD_PATH.unshift lib unless $LOAD_PATH.include?(lib)
require 'mocha/version'

Gem::Specification.new do |s|
  s.name = 'mocha'
  s.version = Mocha::VERSION
  s.licenses = ['MIT', 'BSD-2-Clause']
  s.required_ruby_version = '>= 1.8.7'

  s.authors = ['James Mead']
  s.description = 'Mocking and stubbing library with JMock/SchMock syntax, which allows mocking and stubbing of methods on real (non-mock) classes.'
  s.email = 'mocha-developer@googlegroups.com'

  s.files = `git ls-files`.split("\n")
  s.files.delete('.travis.yml')
  s.files.delete('.gitignore')

  s.homepage = 'http://gofreerange.com/mocha/docs'
  s.require_paths = ['lib']
  s.summary = 'Mocking and stubbing library'
  s.has_rdoc = 'yard'

  s.add_dependency('metaclass', '~> 0.0.1')

  unless s.respond_to?(:add_development_dependency)
    class << s
      def add_development_dependency(*args)
        add_dependency(*args)
      end
    end
  end

  if RUBY_VERSION >= '1.9.3'
    s.add_development_dependency('rake')
  else
    # Rake >= v11 does not support Ruby < v1.9.3 so use
    s.add_development_dependency('rake', '~> 10.0')
  end
  s.add_development_dependency('introspection', '~> 0.0.1')
  if RUBY_VERSION >= '2.2.0'
    # No test libraries in standard library
    s.add_development_dependency('minitest')
  end
  if RUBY_VERSION >= '1.9.2'
    s.add_development_dependency('rubocop')
  end
  if ENV['MOCHA_GENERATE_DOCS']
    s.add_development_dependency('redcarpet')
    s.add_development_dependency('yard')
  end
end