File: changelog

package info (click to toggle)
ruby-netcdf 0.7.2-3
  • links: PTS, VCS
  • area: main
  • in suites: bullseye, buster, sid
  • size: 1,208 kB
  • sloc: ansic: 4,058; ruby: 1,743; makefile: 14; csh: 6
file content (151 lines) | stat: -rw-r--r-- 4,900 bytes parent folder | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
135
136
137
138
139
140
141
142
143
144
145
146
147
148
149
150
151
ruby-netcdf (0.7.2-3) unstable; urgency=medium

  * Team upload.
  * Drop autopkgtest to test installability.
    (Closes: #905122)
  * Add lintian override for testsuite-autopkgtest-missing.

 -- Bas Couwenberg <sebastic@debian.org>  Wed, 01 Aug 2018 19:17:24 +0200

ruby-netcdf (0.7.2-2) unstable; urgency=medium

  * Team upload.
  * Update copyright-format URL to use HTTPS.
  * Update Vcs-* URLs for Salsa.
  * Bump Standards-Version to 4.1.5, no changes.
  * Add autopkgtest to test installability.
  * Update watch file to use gemwatch.debian.net.
  * Enable all hardening buildflags.
  * Add lintian override for hardening-no-fortify-functions.

 -- Bas Couwenberg <sebastic@debian.org>  Sun, 29 Jul 2018 19:38:31 +0200

ruby-netcdf (0.7.2-1) unstable; urgency=medium

  [ Bas Couwenberg ]
  * Bump Standards-Version to 3.9.8, no changes.
  * Add patch to fix 'length' spelling error.

  [ Youhei SASAKI ]
  * New upstream version 0.7.2
  * Refresh patches
  * set DH_RUBY_GEMSPEC explicitly
  * Drop dh_installchangelogs: removed from upstream
  * Drop ruby-netcdf.examples: Drop bin/ from upstream

 -- Youhei SASAKI <uwabami@gfd-dennou.org>  Wed, 28 Sep 2016 16:04:29 +0900

ruby-netcdf (0.7.1.1-7) unstable; urgency=medium

  * Remove dbg package
  * Add patch: fix spelling error
  * Fix lintian warning: vcs-field-uses-insecure-uri
  * Rebuild against Ruby 2.3
  * Bump Standard Version: 3.9.7

 -- Youhei SASAKI <uwabami@gfd-dennou.org>  Tue, 01 Mar 2016 18:02:08 +0900

ruby-netcdf (0.7.1.1-6) unstable; urgency=medium

  * Add patch: Replace git execution from gemspec

 -- Youhei SASAKI <uwabami@gfd-dennou.org>  Mon, 07 Dec 2015 02:19:35 +0900

ruby-netcdf (0.7.1.1-5) unstable; urgency=medium

  * Update debian/changelog
  * Refresh patch: fix location of netcdf_miss.rb
  * Drop obsolete lintian-overrides: thanks to Sebastiaan Couwenberg

 -- Youhei SASAKI <uwabami@gfd-dennou.org>  Wed, 02 Sep 2015 21:20:50 +0900

ruby-netcdf (0.7.1.1-4) unstable; urgency=medium

  * Add lintian overrides for wheezy backports

 -- Youhei SASAKI <uwabami@gfd-dennou.org>  Thu, 27 Aug 2015 19:54:31 +0900

ruby-netcdf (0.7.1.1-3) unstable; urgency=medium

  * Team upload.
  * Update copyright file, rename license shortnames:
    - GPL-2.0+ -> GPL-2+
    - Ruby's   -> Ruby
  * Rebuild for netcdf transition.

 -- Bas Couwenberg <sebastic@debian.org>  Mon, 24 Aug 2015 15:51:17 +0200

ruby-netcdf (0.7.1.1-2) unstable; urgency=medium

  * Add patch: to support NetCDF 4.4.0-rc version
    Thanks to Bas Couwenberg!

 -- Youhei SASAKI <uwabami@gfd-dennou.org>  Fri, 31 Jul 2015 12:05:12 +0900

ruby-netcdf (0.7.1.1-1) unstable; urgency=medium

  [ Bas Couwenberg ]
  * Add gbp.conf to use pristine-tar by default.
  * Restructure control file with cme.

  [ Youhei SASAKI ]
  * Update debian/watch: use gemwatch
  * Imported Upstream version 0.7.1.1 (Closes: #793976)
    - Thanks to Bas Couwenberg!
  * Running all tests during build
  * Refresh patches
  * Install "demo", "bin" as examples

 -- Youhei SASAKI <uwabami@gfd-dennou.org>  Thu, 30 Jul 2015 19:23:10 +0900

ruby-netcdf (0.6.6-2) unstable; urgency=medium

  * Bump Standard Version: 3.9.5
  * Use canonical Vcs-* field
  * Drop obsolete DM-permission entry
  * Drop Transitional Packages
  * Update copyright foramt/1.0
  * Update debian/compat: 9
  * Drop old lintian-overrides

 -- Youhei SASAKI <uwabami@gfd-dennou.org>  Mon, 20 Jan 2014 00:38:07 +0900

ruby-netcdf (0.6.6-1) unstable; urgency=low

  * New Upstream version 0.6.6
  * Update watch
  * Add unapply-patches to debian/sources/local-options
  * Update patches: for gbp-pq
  * Rebuild against new NetCDF packages
  * New patch 0004-Fix-FTBFS-Hardening.patch (Closes: #676195)
    - Thanks to Lucas Nussbaum!
  * Add lintian-overrides for transitonal packages
  * Add lintian-overrides: hardening-no-fortify-functions

 -- Youhei SASAKI <uwabami@gfd-dennou.org>  Tue, 12 Jun 2012 18:51:13 +0900

ruby-netcdf (0.6.5-2) unstable; urgency=low

  * Bump standard-version: 3.9.2
  * Update with files generated by dh-make-ruby:
    - debian/rules
    - debian/watch
  * Updating the package as for the new Ruby practices
    - Renaming binary package to ruby-netcdf, ruby-netcdf-dbg
    - Migrate to gem2deb
      - removed build dependency on cdbs and ruby-pkg-tools
    - Added XS-Ruby-Versions field to debian/control
  * debian/source/format: using '3.0 (quilt)'
  * Added transitional packages in debian/control to allow smooth upgrades
    from Squeeze.
    - ruby-netcdf Provides, Replaces and Conflicts with past packages
      - netcdf-ruby, netcdf-ruby1.8, netcdf-ruby1.9.1
        netcdf-ruby1.8-dbg, netcdf-ruby1.9.1-dbg

 -- Youhei SASAKI <uwabami@gfd-dennou.org>  Thu, 28 Apr 2011 20:57:04 +0900

ruby-netcdf (0.6.5-1) unstable; urgency=low

  * Initial Release (Closes: #542144)

 -- Youhei SASAKI <uwabami@gfd-dennou.org>  Mon, 13 Dec 2010 17:35:12 +0900