File: changelog

package info (click to toggle)
ruby-oj 3.7.6-1
  • links: PTS, VCS
  • area: main
  • in suites: buster, sid
  • size: 1,508 kB
  • sloc: ansic: 16,262; ruby: 10,577; makefile: 2
file content (263 lines) | stat: -rw-r--r-- 8,625 bytes parent folder | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
135
136
137
138
139
140
141
142
143
144
145
146
147
148
149
150
151
152
153
154
155
156
157
158
159
160
161
162
163
164
165
166
167
168
169
170
171
172
173
174
175
176
177
178
179
180
181
182
183
184
185
186
187
188
189
190
191
192
193
194
195
196
197
198
199
200
201
202
203
204
205
206
207
208
209
210
211
212
213
214
215
216
217
218
219
220
221
222
223
224
225
226
227
228
229
230
231
232
233
234
235
236
237
238
239
240
241
242
243
244
245
246
247
248
249
250
251
252
253
254
255
256
257
258
259
260
261
262
263
ruby-oj (3.7.6-1) unstable; urgency=medium

  * New upstream version 3.7.6
    fixes issue for 32bit architectures (Closes: #914546)    
  * Drop 04_skip_failing_test_914546.patch, not needed anymore
  * Bump Standards-Version to 4.3.0 (no changes needed)

 -- Cédric Boutillier <boutil@debian.org>  Fri, 04 Jan 2019 08:22:12 +0100

ruby-oj (3.7.1-2) unstable; urgency=medium

  * Add 04_skip_failing_test_914546.patch disabling test_time_neg, failing on
    32 bit architecture, to decrease severity of bug #914546.

 -- Cédric Boutillier <boutil@debian.org>  Fri, 28 Dec 2018 00:55:46 +0100

ruby-oj (3.7.1-1) unstable; urgency=medium

  * New upstream version 3.7.1
  * Bump Standards-Version to 4.2.1 (no changes needed)

 -- Cédric Boutillier <boutil@debian.org>  Thu, 22 Nov 2018 09:14:48 +0100

ruby-oj (3.6.6-1) unstable; urgency=medium

  * New upstream version 3.6.6

 -- Cédric Boutillier <boutil@debian.org>  Fri, 17 Aug 2018 04:34:54 +0200

ruby-oj (3.6.5-1) unstable; urgency=medium

  * Bump debhelper compatibility level to 11
  * New upstream version 3.6.5
  * Use salsa.debian.org in Vcs-* fields
  * Move debian/watch to gemwatch.debian.net
  * Bump Standards-Version to 4.1.5 (no changes needed)

 -- Cédric Boutillier <boutil@debian.org>  Tue, 31 Jul 2018 00:48:10 +0200

ruby-oj (3.4.0-1) unstable; urgency=medium

  * New upstream version 3.4.0
    + The 3.x series has support for Ruby 2.5 since 3.3.6 (Closes: #888131)
  * Bump Standards-Version to 4.1.3 (no changes needed)
  * Use https for hps for homepage and watch file
  * Set Multi-Arch: same

 -- Cédric Boutillier <boutil@debian.org>  Sun, 04 Feb 2018 22:27:09 +0100

ruby-oj (3.3.9-1~exp1) experimental; urgency=medium

  * New upstream version 3.3.6
  * Refresh 01_dont_mess_with_loadpath.patch
  * Bump Standards-Version to 4.1.1 (no changes needed)
  * Bump debhelper compatibility level to 10
  * Run tests by groups, like upstream

 -- Cédric Boutillier <boutil@debian.org>  Sun, 26 Nov 2017 00:43:17 +0100

ruby-oj (2.17.4-1) unstable; urgency=medium

  * Team upload
  * New upstream release

 -- Pirate Praveen <praveen@debian.org>  Fri, 23 Sep 2016 16:13:17 +0530

ruby-oj (2.17.3-1) unstable; urgency=medium

  * Imported Upstream version 2.17.3

 -- Cédric Boutillier <boutil@debian.org>  Wed, 24 Aug 2016 12:13:26 +0200

ruby-oj (2.17.1-1) unstable; urgency=medium

  * Imported Upstream version 2.17.1
    + fix test failure on i386 (Closes: #830247)
    + add /test_mimic_rails_datetime.rb to the list of skipped tests because
      of rails dependency

 -- Cédric Boutillier <boutil@debian.org>  Sat, 09 Jul 2016 08:40:10 +0200

ruby-oj (2.16.1-1) unstable; urgency=medium

  * Imported Upstream version 2.16.1

 -- Cédric Boutillier <boutil@debian.org>  Thu, 23 Jun 2016 17:01:16 +0200

ruby-oj (2.15.1-1) unstable; urgency=medium

  * Imported Upstream version 2.15.1
  * Bump debhelper compatibility level to 9
  * Remove version in the gem2deb build-dependency
  * Use https:// in Vcs-* fields
  * Bump Standards-Version to 3.9.8 (no changes needed)
  * debian/patches:
    + drop 02_avoid_name_conflict_with_ext.patch, not needed anymore
    + drop 0001-Updated-for-Ruby-2.3.0.patch, applied upstream
    + refresh 03_find_test_helper.patch
  + Exclude test_bigd, using rails

 -- Cédric Boutillier <boutil@debian.org>  Thu, 02 Jun 2016 00:15:36 +0200

ruby-oj (2.12.10-4) unstable; urgency=medium

  * Team upload.
  * Add Ruby 2.3 patch from upstream (0001-Updated-for-Ruby-2.3.0.patch)
    (Closes: #815771)

 -- Antonio Terceiro <terceiro@debian.org>  Wed, 24 Feb 2016 11:00:03 -0300

ruby-oj (2.12.10-3) unstable; urgency=medium

  * Team upload.
  * Also remove Build-Depends: ruby-railties as I intended to.

 -- Christian Hofstaedtler <zeha@debian.org>  Tue, 08 Sep 2015 15:30:16 +0000

ruby-oj (2.12.10-2) unstable; urgency=medium

  * Team upload.
  * Don't build-depend on ruby-activemodel/activesupport, to cut
    dependency chain at a sane point. Oj has integration with rails,
    but doesn't actively need rails. This also disables the test for
    the rails integration.

 -- Christian Hofstaedtler <zeha@debian.org>  Tue, 08 Sep 2015 11:30:22 +0000

ruby-oj (2.12.10-1) unstable; urgency=medium

  * Imported Upstream version 2.12.10
  * Autopkgtest: rely on default behaviour for Ruby packages instead of
    implementing explicit tests (which were missing some build-deps anyway)

 -- Cédric Boutillier <boutil@debian.org>  Mon, 27 Jul 2015 05:19:31 +0200

ruby-oj (2.12.9-1) unstable; urgency=medium

  * Imported Upstream version 2.12.9

 -- Cédric Boutillier <boutil@debian.org>  Wed, 24 Jun 2015 10:20:35 +0200

ruby-oj (2.12.8-1) unstable; urgency=medium

  * Imported Upstream version 2.12.8
  * Drop 90_32bit_fix.patch, applied upstream

 -- Cédric Boutillier <boutil@debian.org>  Sun, 24 May 2015 23:04:30 +0200

ruby-oj (2.12.5-2) unstable; urgency=medium

  * Apply upstream patch 90_32bit_fix.patch for 32 bit architectures
    + solves a test failure for those architectures because of a wrong type.

 -- Cédric Boutillier <boutil@debian.org>  Tue, 05 May 2015 16:18:03 +0200

ruby-oj (2.12.5-1) unstable; urgency=medium

  * Imported Upstream version 2.12.5
  * The source code has relicensed from BSD-3-clause to Expat
    + change the license of the packaging accordingly
  * ruby-oj has now integration with ruby-activesupport
    + adapt build dependency accordingly
  * Run every test in isolation because of interdependencies between the tests
    + run also tests under test/isolated
  * Add 03_find_test_helper.patch: fix relative path in require to find
    test/helper.rb in test/test_debian.rb

 -- Cédric Boutillier <boutil@debian.org>  Fri, 01 May 2015 21:46:50 +0200

ruby-oj (2.10.3-2) unstable; urgency=medium

  * Imported Upstream version 2.10.3
  * Bump Standards-Version to 3.9.6
  * Set Testsuite field to autopkgtest-pkg-ruby

 -- Cédric Boutillier <boutil@debian.org>  Tue, 07 Oct 2014 23:47:05 +0200

ruby-oj (2.10.2-1) unstable; urgency=medium

  * Imported Upstream version 2.10.2
    + fix string corruption causing problems in test_io_string tests
  * Remove 03_deactivate_test_io_string.patch, not needed anymore
  * Add autopkgtest support

 -- Cédric Boutillier <boutil@debian.org>  Wed, 27 Aug 2014 05:42:00 +0200

ruby-oj (2.10.1-1) unstable; urgency=medium

  [ Caitlin Matos ]
  * Team upload
  * New upstream release
  * Versioned build dependency for ruby-minitest

  [ Cédric Boutillier ]
  * Add 03_deactivate_test_io_string.patch to deactivate tests causing others
    to fail on some architectures (Closes: #754761)

 -- Caitlin Matos <caitlin.matos@zoho.com>  Mon, 18 Aug 2014 17:53:34 -0400

ruby-oj (2.9.6-1) unstable; urgency=medium

  * Imported Upstream version 2.9.6
  * Refresh 01_dont_mess_with_loadpath.patch
  * Modify ruby-tests.rb to load individual test files
  * Clean some json files after the tests
  * Build-depend on ruby-minitest

 -- Cédric Boutillier <boutil@debian.org>  Mon, 23 Jun 2014 06:51:59 +0200

ruby-oj (2.9.4-1) unstable; urgency=medium

  * Imported Upstream version 2.9.4
  * Drop support for ruby2.0

 -- Cédric Boutillier <boutil@debian.org>  Thu, 29 May 2014 23:59:19 +0200

ruby-oj (2.7.3-1) unstable; urgency=medium

  * Imported Upstream version 2.7.3

 -- Cédric Boutillier <boutil@debian.org>  Mon, 14 Apr 2014 16:16:42 +0200

ruby-oj (2.5.5-1) unstable; urgency=medium

  * Imported Upstream version 2.5.5
  * Refresh 02_avoid_name_conflict_with_ext.patch

 -- Cédric Boutillier <boutil@debian.org>  Sat, 01 Mar 2014 00:17:00 +0100

ruby-oj (2.5.3-1) unstable; urgency=medium

  * Imported Upstream version 2.5.3

 -- Cédric Boutillier <boutil@debian.org>  Fri, 10 Jan 2014 08:25:41 +0100

ruby-oj (2.4.0-1) unstable; urgency=medium

  [ Jérémy Bobbio ]
  * Add git-buildpackage configuration

  [ Cédric Boutillier ]
  * Imported Upstream version 2.4.0
    + fix build on sparc
  * Bump Standards-Version to 3.9.5 (no changes needed)
  * Bump version in gem2deb build-dependency to ensure the extension is built
    for Ruby2.0

 -- Cédric Boutillier <boutil@debian.org>  Mon, 09 Dec 2013 07:58:50 +0100

ruby-oj (2.1.4-1) unstable; urgency=low

  * Imported Upstream version 2.1.4
  * debian/patches:
    + refresh and fix extension of 02_avoid_name_conflict_with_ext.patch
    + drop 03_disable_deep_nest_test.patch, not needed anymore

 -- Cédric Boutillier <boutil@debian.org>  Wed, 11 Sep 2013 23:01:38 +0200

ruby-oj (2.0.10-1) unstable; urgency=low

  * Initial release (Closes: #703558)

 -- Cédric Boutillier <boutil@debian.org>  Thu, 21 Mar 2013 00:43:03 +0100