File: omniauth-atlassian-oauth2.gemspec

package info (click to toggle)
ruby-omniauth-atlassian-oauth2 0.2.0-2
  • links: PTS, VCS
  • area: main
  • in suites: bookworm, bullseye, sid
  • size: 120 kB
  • sloc: ruby: 62; makefile: 4
file content (29 lines) | stat: -rw-r--r-- 1,070 bytes parent folder | download | duplicates (2)
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
# frozen_string_literal: true

require File.expand_path(
  File.join('..', 'lib', 'omniauth', 'atlassian_oauth2', 'version'),
  __FILE__
)

Gem::Specification.new do |gem|
  gem.name          = 'omniauth-atlassian-oauth2'
  gem.version       = OmniAuth::AtlassianOauth2::VERSION
  gem.license       = 'MIT'
  gem.summary       = %(An Atlassian OAuth2 strategy for OmniAuth 1.x)
  gem.description   = %(An Atlassian OAuth2 strategy for OmniAuth 1.x. This allows you to login to Atlassian with your ruby app.)
  gem.authors       = ['Ben Standefer']
  gem.email         = ['benstandefer@gmail.com']
  gem.homepage      = 'https://github.com/aguynamedben/omniauth-atlassian-oauth2'

  gem.files         = `git ls-files`.split("\n")
  gem.require_paths = ['lib']

  gem.required_ruby_version = '>= 2.1'

  gem.add_runtime_dependency 'omniauth', '>= 1.1.1'
  gem.add_runtime_dependency 'omniauth-oauth2', '>= 1.5'

  gem.add_development_dependency 'rake', '~> 12.0'
  gem.add_development_dependency 'rspec', '~> 3.6'
  gem.add_development_dependency 'rubocop', '~> 0.49'
end