File: Rakefile

package info (click to toggle)
ruby-os 0.9.6-1.1
  • links: PTS, VCS
  • area: main
  • in suites: bullseye, sid
  • size: 128 kB
  • sloc: ruby: 417; makefile: 3
file content (26 lines) | stat: -rw-r--r-- 1,028 bytes parent folder | download | duplicates (3)
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
require 'rubygems' if RUBY_VERSION < '1.9.0'
require 'rake'

# Don't forget to run rake gemspec with each release! ... I think...

begin
  require 'jeweler'
  Jeweler::Tasks.new do |gem|
    gem.name = "os"
    gem.summary = %Q{Simple and easy way to know if you're on windows or not (reliably), as well as how many bits the OS is, etc.}
    gem.description = %Q{The OS gem allows for some useful and easy functions, like OS.windows? (=> true or false) OS.bits ( => 32 or 64) etc"}
    gem.email = "rogerpack2005@gmail.com"
    gem.homepage = "http://github.com/rdp/os"
    gem.authors = ["rdp", "David McCullars"]
    # gem is a Gem::Specification... see http://www.rubygems.org/read/chapter/20 for additional settings
    # gem.add_development_dependency "fast_require"
    gem.add_development_dependency "rspec", ">= 2.0"
  end
rescue LoadError
  puts "Jeweler (or a dependency) not available. Install it with: gem install jeweler"
end

require 'rspec/core/rake_task'
RSpec::Core::RakeTask.new(:spec)
task :default => :spec