1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27
|
Description: fix the load path of the extension
The require of the extension in the Ruby library assumes it is in stalled
as a gem and hence loads 'ox/ox', but it should just load the installed
'ox.so'.
Author: Paul van Tilburg <paulvt@debian.org>
Forwarded: not-needed
Bug-Debian: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=1042218
Last-Update: 2023-08-06
lib/ox.rb | 6 +-----
1 file changed, 1 insertion(+), 5 deletions(-)
diff --git a/lib/ox.rb b/lib/ox.rb
index a779163..1fdca82 100644
@@ -76,8 +76,4 @@ require 'ox/bag'
require 'ox/sax'
# C extension
-begin
- require_relative 'ox.so'
-rescue LoadError
- require 'ox/ox'
-end
+require 'ox.so'
|